aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-08 02:34:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-08 02:34:18 +0000
commite2fac9a41a6932dccc49ee6e61c190c64ef5e150 (patch)
treeb986236728065b99416dd12cd32f799022aaa38a /target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
parent8e88bb54ba6a806865059ee47c13acb581c05dfb (diff)
downloadupstream-e2fac9a41a6932dccc49ee6e61c190c64ef5e150.tar.gz
upstream-e2fac9a41a6932dccc49ee6e61c190c64ef5e150.tar.bz2
upstream-e2fac9a41a6932dccc49ee6e61c190c64ef5e150.zip
update work in progress rewritten bcm947xx code. wifi and usb seem to be working, flash access still has problems
SVN-Revision: 6276
Diffstat (limited to 'target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile')
-rw-r--r--target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
new file mode 100644
index 0000000000..9f85d225dd
--- /dev/null
+++ b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
@@ -0,0 +1,14 @@
+ssb-driver-chipcommon-y := driver_chipcommon/chipcommon.o
+ssb-driver-mips-$(CONFIG_BCM947XX) := driver_mips/mips.o
+ssb-driver-pci-$(CONFIG_SSB_DRIVER_PCICORE) := driver_pci/pcicore.o
+
+ssb-$(CONFIG_SSB_PCIHOST) += pci.o
+ssb-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
+
+obj-$(CONFIG_SSB) += ssb.o
+
+ssb-objs := core.o scan.o \
+ $(ssb-y) $(ssb-m) \
+ $(ssb-driver-chipcommon-y) \
+ $(ssb-driver-mips-y) \
+ $(ssb-driver-pci-y)