aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-07-29 11:55:14 +0200
committerJohn Crispin <john@phrozen.org>2018-07-30 08:11:36 +0200
commit7516a960113d512cb2909f40bd07caf2a6c547b1 (patch)
tree0328dfad9f6e70fa43b3c20475343433008e1c77 /target/linux/brcm2708
parentdf495305f36216c972255f62d0d0b6f8d4567b87 (diff)
downloadupstream-7516a960113d512cb2909f40bd07caf2a6c547b1.tar.gz
upstream-7516a960113d512cb2909f40bd07caf2a6c547b1.tar.bz2
upstream-7516a960113d512cb2909f40bd07caf2a6c547b1.zip
brcm2708: split sdcard.img.gz into a sysupgrade and factory image
@vahid-dan reported a issue with extracting the rpi images with Gnome's Archive Manager: "Ubuntu Archive Manager cannot extract the file and it just throws a general error message: "An error occurred while extracting files". <https://forum.lede-project.org/t/corrupted-pre-built-v18-06-0-rc2-image-for-rpi> @blogic told me to split the single sdcard.img.gz for the RPi into a sysupgrade and a factory image for all brcm2708 targets. The factory images will have no metadata attached, this way these utilities that can't deal with the attached metadata will not fail for no reason. Cc: John Crispin <john@phrozen.org> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 80a019270d..aedea94451 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -49,8 +49,9 @@ endef
define Device/Default
KERNEL := kernel-bin | kernel-img
KERNEL_IMG := kernel.img
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
+ IMAGES := factory.img.gz sysupgrade.img.gz
+ IMAGE/sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
+ IMAGE/factory.img.gz := boot-img | sdcard-img | gzip
endef
define Device/rpi