aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-02-28 20:29:40 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-02-28 20:29:40 +0000
commit6881251b7499378edfb05db191b977c1c79f3615 (patch)
tree79f70aee6c044e5abdea9f8df8599291c0245615 /target/linux/brcm2708
parent44de5c8d011ffb407e81515cdf1e29c3a30082b6 (diff)
downloadupstream-6881251b7499378edfb05db191b977c1c79f3615.tar.gz
upstream-6881251b7499378edfb05db191b977c1c79f3615.tar.bz2
upstream-6881251b7499378edfb05db191b977c1c79f3615.zip
brcm2708: define KERNELNAME accordingly
Define KERNELNAME to Image to get the build system to copy this image over $(KDIR) automatically for us. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39768 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/Makefile2
-rw-r--r--target/linux/brcm2708/image/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 8ab34eb5ee..f83d6f5635 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -25,4 +25,6 @@ define Target/Description
Currently produces SD Card image for Raspberry Pi.
endef
+KERNELNAME="Image"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 6b4cf141a6..ae977a613e 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -8,10 +8,6 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
include $(INCLUDE_DIR)/host.mk
-define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
-endef
-
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))