aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2017-03-04 19:37:50 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2017-03-04 19:37:50 +0100
commitbaad22eed3ea3242051bbde6ebf56e74deb11ea6 (patch)
tree2980f26a82772c37d7d655871780fad0f3a4aeb1 /target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch
parentf229f4af31731badc2dec27c9bdef9f5fa8f7433 (diff)
downloadupstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.tar.gz
upstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.tar.bz2
upstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.zip
brcm2708: update linux 4.9 patches to latest version
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch')
-rw-r--r--target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch b/target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch
deleted file mode 100644
index 1dfed15876..0000000000
--- a/target/linux/brcm2708/patches-4.9/0075-Update-ds1307-driver-for-device-tree-support.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 682c095597876ff7d669f92dc2a0f1f49526444c Mon Sep 17 00:00:00 2001
-From: Ryan Coe <bluemrp9@gmail.com>
-Date: Sat, 31 Jan 2015 18:25:49 -0700
-Subject: [PATCH] Update ds1307 driver for device-tree support
-
-Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
----
- drivers/rtc/rtc-ds1307.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
---- a/drivers/rtc/rtc-ds1307.c
-+++ b/drivers/rtc/rtc-ds1307.c
-@@ -1675,6 +1675,14 @@ static int ds1307_remove(struct i2c_clie
- return 0;
- }
-
-+#ifdef CONFIG_OF
-+static const struct of_device_id ds1307_of_match[] = {
-+ { .compatible = "maxim,ds1307" },
-+ { }
-+};
-+MODULE_DEVICE_TABLE(of, ds1307_of_match);
-+#endif
-+
- static struct i2c_driver ds1307_driver = {
- .driver = {
- .name = "rtc-ds1307",