aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-04-07 21:25:10 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-04-07 21:25:10 +0200
commita8d4d71c41ff0158c2026cac5981e39702167da9 (patch)
tree0c54ec3eb59f5bab6aa7318d14c92ff875412202 /target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
parent59e0e88c22007fd77ee9c6c8e02a689889a5f597 (diff)
downloadupstream-a8d4d71c41ff0158c2026cac5981e39702167da9.tar.gz
upstream-a8d4d71c41ff0158c2026cac5981e39702167da9.tar.bz2
upstream-a8d4d71c41ff0158c2026cac5981e39702167da9.zip
brcm2708: update to latest version
As usual these patches were extracted from the raspberry pi repo: https://github.com/raspberrypi/linux/commits/rpi-4.4.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch')
-rw-r--r--target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch170
1 files changed, 0 insertions, 170 deletions
diff --git a/target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch b/target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
deleted file mode 100644
index 2c5fe9907f..0000000000
--- a/target/linux/brcm2708/patches-4.4/0074-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
+++ /dev/null
@@ -1,170 +0,0 @@
-From a2b52a3af1314e2b691d9518afb3051193758671 Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.org>
-Date: Fri, 6 Feb 2015 13:50:57 +0000
-Subject: [PATCH 074/170] BCM270x_DT: Add pwr_led, and the required "input"
- trigger
-
-The "input" trigger makes the associated GPIO an input. This is to support
-the Raspberry Pi PWR LED, which is driven by external hardware in normal use.
-
-N.B. pwr_led is not available on Model A or B boards.
-
-leds-gpio: Implement the brightness_get method
-
-The power LED uses some clever logic that means it is driven
-by a voltage measuring circuit when configured as input, otherwise
-it is driven by the GPIO output value. This patch wires up the
-brightness_get method for leds-gpio so that user-space can monitor
-the LED value via /sys/class/gpio/led1/brightness. Using the input
-trigger this returns an indication of the system power health,
-otherwise it is just whatever value the trigger has written most
-recently.
-
-See: https://github.com/raspberrypi/linux/issues/1064
----
- drivers/leds/leds-gpio.c | 18 +++++++++++-
- drivers/leds/trigger/Kconfig | 7 +++++
- drivers/leds/trigger/Makefile | 1 +
- drivers/leds/trigger/ledtrig-input.c | 54 ++++++++++++++++++++++++++++++++++++
- include/linux/leds.h | 3 ++
- 5 files changed, 82 insertions(+), 1 deletion(-)
- create mode 100644 drivers/leds/trigger/ledtrig-input.c
-
---- a/drivers/leds/leds-gpio.c
-+++ b/drivers/leds/leds-gpio.c
-@@ -42,6 +42,13 @@ static void gpio_led_work(struct work_st
- led_dat->platform_gpio_blink_set(led_dat->gpiod,
- led_dat->new_level, NULL, NULL);
- led_dat->blinking = 0;
-+ } else if (led_dat->cdev.flags & SET_GPIO_INPUT) {
-+ gpiod_direction_input(led_dat->gpiod);
-+ led_dat->cdev.flags &= ~SET_GPIO_INPUT;
-+ }
-+ else if (led_dat->cdev.flags & SET_GPIO_OUTPUT) {
-+ gpiod_direction_output(led_dat->gpiod, led_dat->new_level);
-+ led_dat->cdev.flags &= ~SET_GPIO_OUTPUT;
- } else
- gpiod_set_value_cansleep(led_dat->gpiod, led_dat->new_level);
- }
-@@ -62,7 +69,8 @@ static void gpio_led_set(struct led_clas
- * seem to have a reliable way to know if we're already in one; so
- * let's just assume the worst.
- */
-- if (led_dat->can_sleep) {
-+ if (led_dat->can_sleep ||
-+ (led_dat->cdev.flags & (SET_GPIO_INPUT | SET_GPIO_OUTPUT) )) {
- led_dat->new_level = level;
- schedule_work(&led_dat->work);
- } else {
-@@ -75,6 +83,13 @@ static void gpio_led_set(struct led_clas
- }
- }
-
-+static enum led_brightness gpio_led_get(struct led_classdev *led_cdev)
-+{
-+ struct gpio_led_data *led_dat =
-+ container_of(led_cdev, struct gpio_led_data, cdev);
-+ return gpiod_get_value_cansleep(led_dat->gpiod) ? LED_FULL : LED_OFF;
-+}
-+
- static int gpio_blink_set(struct led_classdev *led_cdev,
- unsigned long *delay_on, unsigned long *delay_off)
- {
-@@ -131,6 +146,7 @@ static int create_gpio_led(const struct
- led_dat->cdev.blink_set = gpio_blink_set;
- }
- led_dat->cdev.brightness_set = gpio_led_set;
-+ led_dat->cdev.brightness_get = gpio_led_get;
- if (template->default_state == LEDS_GPIO_DEFSTATE_KEEP)
- state = !!gpiod_get_value_cansleep(led_dat->gpiod);
- else
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -126,4 +126,11 @@ config LEDS_TRIGGER_USBDEV
- This allows LEDs to be controlled by the presence/activity of
- an USB device. If unsure, say N.
-
-+config LEDS_TRIGGER_INPUT
-+ tristate "LED Input Trigger"
-+ depends on LEDS_TRIGGERS
-+ help
-+ This allows the GPIOs assigned to be LEDs to be initialised to inputs.
-+ If unsure, say Y.
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/trigger/Makefile
-+++ b/drivers/leds/trigger/Makefile
-@@ -8,3 +8,4 @@ obj-$(CONFIG_LEDS_TRIGGER_CPU) += ledtr
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
- obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
- obj-$(CONFIG_LEDS_TRIGGER_CAMERA) += ledtrig-camera.o
-+obj-$(CONFIG_LEDS_TRIGGER_INPUT) += ledtrig-input.o
---- /dev/null
-+++ b/drivers/leds/trigger/ledtrig-input.c
-@@ -0,0 +1,54 @@
-+/*
-+ * Set LED GPIO to Input "Trigger"
-+ *
-+ * Copyright 2015 Phil Elwell <phil@raspberrypi.org>
-+ *
-+ * Based on Nick Forbes's ledtrig-default-on.c.
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License version 2 as
-+ * published by the Free Software Foundation.
-+ *
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/kernel.h>
-+#include <linux/init.h>
-+#include <linux/leds.h>
-+#include <linux/gpio.h>
-+#include "../leds.h"
-+
-+static void input_trig_activate(struct led_classdev *led_cdev)
-+{
-+ led_cdev->flags |= SET_GPIO_INPUT;
-+ led_set_brightness_async(led_cdev, 0);
-+}
-+
-+static void input_trig_deactivate(struct led_classdev *led_cdev)
-+{
-+ led_cdev->flags |= SET_GPIO_OUTPUT;
-+ led_set_brightness_async(led_cdev, 0);
-+}
-+
-+static struct led_trigger input_led_trigger = {
-+ .name = "input",
-+ .activate = input_trig_activate,
-+ .deactivate = input_trig_deactivate,
-+};
-+
-+static int __init input_trig_init(void)
-+{
-+ return led_trigger_register(&input_led_trigger);
-+}
-+
-+static void __exit input_trig_exit(void)
-+{
-+ led_trigger_unregister(&input_led_trigger);
-+}
-+
-+module_init(input_trig_init);
-+module_exit(input_trig_exit);
-+
-+MODULE_AUTHOR("Phil Elwell <phil@raspberrypi.org>");
-+MODULE_DESCRIPTION("Set LED GPIO to Input \"trigger\"");
-+MODULE_LICENSE("GPL");
---- a/include/linux/leds.h
-+++ b/include/linux/leds.h
-@@ -48,6 +48,9 @@ struct led_classdev {
- #define SET_BRIGHTNESS_ASYNC (1 << 21)
- #define SET_BRIGHTNESS_SYNC (1 << 22)
- #define LED_DEV_CAP_FLASH (1 << 23)
-+ /* Additions for Raspberry Pi PWR LED */
-+#define SET_GPIO_INPUT (1 << 30)
-+#define SET_GPIO_OUTPUT (1 << 31)
-
- /* Set LED brightness level */
- /* Must not sleep, use a workqueue if needed */