aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-02-04 19:02:53 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-02-04 19:14:13 +0100
commit84d555aa74434392b682fd9eb0fa701c89a046d6 (patch)
treebcc0a9bf058757da14054bce61a8cb8b8c9cd873 /target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch
parent953973c2991e8640549a55df7a0574a1abac8644 (diff)
downloadupstream-84d555aa74434392b682fd9eb0fa701c89a046d6.tar.gz
upstream-84d555aa74434392b682fd9eb0fa701c89a046d6.tar.bz2
upstream-84d555aa74434392b682fd9eb0fa701c89a046d6.zip
brcm2708: update to latest patches from RPi foundation
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch')
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch246
1 files changed, 0 insertions, 246 deletions
diff --git a/target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch b/target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch
deleted file mode 100644
index 0ff97759d9..0000000000
--- a/target/linux/brcm2708/patches-4.19/950-0697-Add-Hifiberry-DAC-DSP-soundcard-driver-3224.patch
+++ /dev/null
@@ -1,246 +0,0 @@
-From f0715f5e178f2f7c0afb719a3a35c8ac250b7586 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?J=C3=B6rg=20Schambacher?=
- <j-schambacher@users.noreply.github.com>
-Date: Thu, 12 Sep 2019 14:57:32 +0200
-Subject: [PATCH] Add Hifiberry DAC+DSP soundcard driver (#3224)
-
-Adds the driver for the Hifiberry DAC+DSP. It supports capture and
-playback depending on the DSP firmware.
-
-Signed-off-by: Joerg Schambacher <joerg@i2audio.com>
----
- arch/arm/boot/dts/overlays/Makefile | 1 +
- arch/arm/boot/dts/overlays/README | 6 ++
- .../overlays/hifiberry-dacplusdsp-overlay.dts | 34 +++++++
- sound/soc/bcm/Kconfig | 7 ++
- sound/soc/bcm/Makefile | 2 +
- sound/soc/bcm/hifiberry_dacplusdsp.c | 90 +++++++++++++++++++
- sound/soc/bcm/rpi-simple-soundcard.c | 19 ++++
- 10 files changed, 162 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/hifiberry-dacplusdsp-overlay.dts
- create mode 100644 sound/soc/bcm/hifiberry_dacplusdsp.c
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -54,6 +54,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
- hifiberry-dacplus.dtbo \
- hifiberry-dacplusadc.dtbo \
- hifiberry-dacplusadcpro.dtbo \
-+ hifiberry-dacplusdsp.dtbo \
- hifiberry-digi.dtbo \
- hifiberry-digi-pro.dtbo \
- hy28a.dtbo \
---- a/arch/arm/boot/dts/overlays/README
-+++ b/arch/arm/boot/dts/overlays/README
-@@ -904,6 +904,12 @@ Params: 24db_digital_gain Allow ga
- master for bit clock and frame clock.
-
-
-+Name: hifiberry-dacplusdsp
-+Info: Configures the HifiBerry DAC+DSP audio card
-+Load: dtoverlay=hifiberry-dacplusdsp
-+Params: <None>
-+
-+
- Name: hifiberry-digi
- Info: Configures the HifiBerry Digi and Digi+ audio card
- Load: dtoverlay=hifiberry-digi
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/hifiberry-dacplusdsp-overlay.dts
-@@ -0,0 +1,34 @@
-+// Definitions for hifiberry DAC+DSP soundcard overlay
-+/dts-v1/;
-+/plugin/;
-+
-+/ {
-+ compatible = "brcm,bcm2835";
-+
-+ fragment@0 {
-+ target = <&i2s>;
-+ __overlay__ {
-+ status = "okay";
-+ };
-+ };
-+
-+ fragment@1 {
-+ target-path = "/";
-+ __overlay__ {
-+ dacplusdsp-codec {
-+ #sound-dai-cells = <0>;
-+ compatible = "hifiberry,dacplusdsp";
-+ status = "okay";
-+ };
-+ };
-+ };
-+
-+ fragment@2 {
-+ target = <&sound>;
-+ __overlay__ {
-+ compatible = "hifiberrydacplusdsp,hifiberrydacplusdsp-soundcard";
-+ i2s-controller = <&i2s>;
-+ status = "okay";
-+ };
-+ };
-+};
---- a/sound/soc/bcm/Kconfig
-+++ b/sound/soc/bcm/Kconfig
-@@ -56,6 +56,13 @@ config SND_BCM2708_SOC_HIFIBERRY_DACPLUS
- help
- Say Y or M if you want to add support for HifiBerry DAC+ADC PRO.
-
-+config SND_BCM2708_SOC_HIFIBERRY_DACPLUSDSP
-+ tristate "Support for HifiBerry DAC+DSP"
-+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
-+ select SND_RPI_SIMPLE_SOUNDCARD
-+ help
-+ Say Y or M if you want to add support for HifiBerry DSP-DAC.
-+
- config SND_BCM2708_SOC_HIFIBERRY_DIGI
- tristate "Support for HifiBerry Digi"
- depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
---- a/sound/soc/bcm/Makefile
-+++ b/sound/soc/bcm/Makefile
-@@ -15,6 +15,7 @@ snd-soc-googlevoicehat-codec-objs := goo
- snd-soc-hifiberry-dacplus-objs := hifiberry_dacplus.o
- snd-soc-hifiberry-dacplusadc-objs := hifiberry_dacplusadc.o
- snd-soc-hifiberry-dacplusadcpro-objs := hifiberry_dacplusadcpro.o
-+snd-soc-hifiberry-dacplusdsp-objs := hifiberry_dacplusdsp.o
- snd-soc-justboom-dac-objs := justboom-dac.o
- snd-soc-rpi-cirrus-objs := rpi-cirrus.o
- snd-soc-rpi-proto-objs := rpi-proto.o
-@@ -40,6 +41,7 @@ obj-$(CONFIG_SND_BCM2708_SOC_GOOGLEVOICE
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS) += snd-soc-hifiberry-dacplus.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUSADC) += snd-soc-hifiberry-dacplusadc.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUSADCPRO) += snd-soc-hifiberry-dacplusadcpro.o
-+obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUSDSP) += snd-soc-hifiberry-dacplusdsp.o
- obj-$(CONFIG_SND_BCM2708_SOC_JUSTBOOM_DAC) += snd-soc-justboom-dac.o
- obj-$(CONFIG_SND_BCM2708_SOC_RPI_CIRRUS) += snd-soc-rpi-cirrus.o
- obj-$(CONFIG_SND_BCM2708_SOC_RPI_PROTO) += snd-soc-rpi-proto.o
---- /dev/null
-+++ b/sound/soc/bcm/hifiberry_dacplusdsp.c
-@@ -0,0 +1,90 @@
-+// SPDX-License-Identifier: GPL-2.0
-+/*
-+ * ASoC Driver for HiFiBerry DAC + DSP
-+ *
-+ * Author: Joerg Schambacher <joscha@schambacher.com>
-+ * Copyright 2018
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/init.h>
-+#include <linux/module.h>
-+#include <linux/of.h>
-+#include <linux/platform_device.h>
-+#include <sound/soc.h>
-+
-+static struct snd_soc_component_driver dacplusdsp_component_driver;
-+
-+static struct snd_soc_dai_driver dacplusdsp_dai = {
-+ .name = "dacplusdsp-hifi",
-+ .capture = {
-+ .stream_name = "DAC+DSP Capture",
-+ .channels_min = 2,
-+ .channels_max = 2,
-+ .rates = SNDRV_PCM_RATE_CONTINUOUS,
-+ .formats = SNDRV_PCM_FMTBIT_S16_LE |
-+ SNDRV_PCM_FMTBIT_S24_LE |
-+ SNDRV_PCM_FMTBIT_S32_LE,
-+ },
-+ .playback = {
-+ .stream_name = "DACP+DSP Playback",
-+ .channels_min = 2,
-+ .channels_max = 2,
-+ .rates = SNDRV_PCM_RATE_CONTINUOUS,
-+ .formats = SNDRV_PCM_FMTBIT_S16_LE |
-+ SNDRV_PCM_FMTBIT_S24_LE |
-+ SNDRV_PCM_FMTBIT_S32_LE,
-+ },
-+ .symmetric_rates = 1};
-+
-+#ifdef CONFIG_OF
-+static const struct of_device_id dacplusdsp_ids[] = {
-+ {
-+ .compatible = "hifiberry,dacplusdsp",
-+ },
-+ {} };
-+MODULE_DEVICE_TABLE(of, dacplusdsp_ids);
-+#endif
-+
-+static int dacplusdsp_platform_probe(struct platform_device *pdev)
-+{
-+ int ret;
-+
-+ ret = snd_soc_register_component(&pdev->dev,
-+ &dacplusdsp_component_driver, &dacplusdsp_dai, 1);
-+ if (ret) {
-+ pr_alert("snd_soc_register_component failed\n");
-+ return ret;
-+ }
-+
-+ return 0;
-+}
-+
-+static int dacplusdsp_platform_remove(struct platform_device *pdev)
-+{
-+ snd_soc_unregister_component(&pdev->dev);
-+ return 0;
-+}
-+
-+static struct platform_driver dacplusdsp_driver = {
-+ .driver = {
-+ .name = "hifiberry-dacplusdsp-codec",
-+ .of_match_table = of_match_ptr(dacplusdsp_ids),
-+ },
-+ .probe = dacplusdsp_platform_probe,
-+ .remove = dacplusdsp_platform_remove,
-+};
-+
-+module_platform_driver(dacplusdsp_driver);
-+
-+MODULE_AUTHOR("Joerg Schambacher <joerg@i2audio.com>");
-+MODULE_DESCRIPTION("ASoC Driver for HiFiBerry DAC+DSP");
-+MODULE_LICENSE("GPL v2");
---- a/sound/soc/bcm/rpi-simple-soundcard.c
-+++ b/sound/soc/bcm/rpi-simple-soundcard.c
-@@ -136,6 +136,23 @@ static struct snd_rpi_simple_drvdata drv
- .dai = snd_googlevoicehat_soundcard_dai,
- };
-
-+static struct snd_soc_dai_link snd_hifiberrydacplusdsp_soundcard_dai[] = {
-+{
-+ .name = "Hifiberry DAC+DSP SoundCard",
-+ .stream_name = "Hifiberry DAC+DSP SoundCard HiFi",
-+ .codec_dai_name = "dacplusdsp-hifi",
-+ .codec_name = "dacplusdsp-codec",
-+ .dai_fmt = SND_SOC_DAIFMT_I2S |
-+ SND_SOC_DAIFMT_NB_NF |
-+ SND_SOC_DAIFMT_CBS_CFS,
-+},
-+};
-+
-+static struct snd_rpi_simple_drvdata drvdata_hifiberrydacplusdsp = {
-+ .card_name = "snd_rpi_hifiberrydacplusdsp_soundcard",
-+ .dai = snd_hifiberrydacplusdsp_soundcard_dai,
-+};
-+
- static struct snd_soc_dai_link snd_hifiberry_amp_dai[] = {
- {
- .name = "HifiBerry AMP",
-@@ -193,6 +210,8 @@ static const struct of_device_id snd_rpi
- .data = (void *) &drvdata_adau1977 },
- { .compatible = "googlevoicehat,googlevoicehat-soundcard",
- .data = (void *) &drvdata_googlevoicehat },
-+ { .compatible = "hifiberrydacplusdsp,hifiberrydacplusdsp-soundcard",
-+ .data = (void *) &drvdata_hifiberrydacplusdsp },
- { .compatible = "hifiberry,hifiberry-amp",
- .data = (void *) &drvdata_hifiberry_amp },
- { .compatible = "hifiberry,hifiberry-dac",