aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-11-10 13:03:18 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2018-12-18 23:19:21 +0200
commitf5919b65d4c671fd5083838c7a445f319f9a13c8 (patch)
tree2c791d2a5dea5bbbb0b85f86f74afce2647c0726 /target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch
parent822b4c3b250a254e74407056ccfd5c6aa38da162 (diff)
downloadupstream-f5919b65d4c671fd5083838c7a445f319f9a13c8.tar.gz
upstream-f5919b65d4c671fd5083838c7a445f319f9a13c8.tar.bz2
upstream-f5919b65d4c671fd5083838c7a445f319f9a13c8.zip
brcm2708: add kernel 4.14 support
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch')
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch b/target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch
new file mode 100644
index 0000000000..27057cd62e
--- /dev/null
+++ b/target/linux/brcm2708/patches-4.14/950-0339-Add-device-tree-overlay-for-HD44780.patch
@@ -0,0 +1,105 @@
+From d1f9b37d299ef8cbd740a3f6cb7f71db887737d6 Mon Sep 17 00:00:00 2001
+From: Jasper Boomer <jasperboomer@gmail.com>
+Date: Sun, 24 Jun 2018 12:20:27 -0400
+Subject: [PATCH 339/454] Add device tree overlay for HD44780
+
+---
+ arch/arm/boot/dts/overlays/Makefile | 1 +
+ arch/arm/boot/dts/overlays/README | 25 ++++++++++
+ .../boot/dts/overlays/hd44780-lcd-overlay.dts | 46 +++++++++++++++++++
+ 3 files changed, 72 insertions(+)
+ create mode 100644 arch/arm/boot/dts/overlays/hd44780-lcd-overlay.dts
+
+--- a/arch/arm/boot/dts/overlays/Makefile
++++ b/arch/arm/boot/dts/overlays/Makefile
+@@ -38,6 +38,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
+ gpio-no-irq.dtbo \
+ gpio-poweroff.dtbo \
+ gpio-shutdown.dtbo \
++ hd44780-lcd.dtbo \
+ hifiberry-amp.dtbo \
+ hifiberry-dac.dtbo \
+ hifiberry-dacplus.dtbo \
+--- a/arch/arm/boot/dts/overlays/README
++++ b/arch/arm/boot/dts/overlays/README
+@@ -639,6 +639,31 @@ Params: gpio_pin GPIO pin
+ external pullup.
+
+
++Name: hd44780-lcd
++Info: Configures an HD44780 compatible LCD display. Uses 4 gpio pins for
++ data, 2 gpio pins for enable and register select and 1 optional pin
++ for enabling/disabling the backlight display.
++Load: dtoverlay=hd44780-lcd,<param>=<val>
++Params: pin_d4 GPIO pin for data pin D4 (default 6)
++
++ pin_d5 GPIO pin for data pin D5 (default 13)
++
++ pin_d6 GPIO pin for data pin D6 (default 19)
++
++ pin_d7 GPIO pin for data pin D7 (default 26)
++
++ pin_en GPIO pin for "Enable" (default 21)
++
++ pin_rs GPIO pin for "Register Select" (default 20)
++
++ pin_bl Optional pin for enabling/disabling the
++ display backlight. (default disabled)
++
++ display_height Height of the display in characters
++
++ display_width Width of the display in characters
++
++
+ Name: hifiberry-amp
+ Info: Configures the HifiBerry Amp and Amp+ audio cards
+ Load: dtoverlay=hifiberry-amp
+--- /dev/null
++++ b/arch/arm/boot/dts/overlays/hd44780-lcd-overlay.dts
+@@ -0,0 +1,46 @@
++/dts-v1/;
++/plugin/;
++
++/ {
++ compatible = "brcm,bcm2835";
++
++ fragment@0 {
++ target-path = "/";
++ __overlay__ {
++ lcd_screen: auxdisplay {
++ compatible = "hit,hd44780";
++
++ data-gpios = <&gpio 6 0>,
++ <&gpio 13 0>,
++ <&gpio 19 0>,
++ <&gpio 26 0>;
++ enable-gpios = <&gpio 21 0>;
++ rs-gpios = <&gpio 20 0>;
++
++ display-height-chars = <2>;
++ display-width-chars = <16>;
++ };
++
++ };
++ };
++
++ fragment@1 {
++ target = <&lcd_screen>;
++ __dormant__ {
++ backlight-gpios = <&gpio 12 0>;
++ };
++ };
++
++ __overrides__ {
++ pin_d4 = <&lcd_screen>,"data-gpios:4";
++ pin_d5 = <&lcd_screen>,"data-gpios:16";
++ pin_d6 = <&lcd_screen>,"data-gpios:28";
++ pin_d7 = <&lcd_screen>,"data-gpios:40";
++ pin_en = <&lcd_screen>,"enable-gpios:4";
++ pin_rs = <&lcd_screen>,"rs-gpios:4";
++ pin_bl = <0>,"+1", <&lcd_screen>,"backlight-gpios:4";
++ display_height = <&lcd_screen>,"display-height-chars:0";
++ display_width = <&lcd_screen>,"display-width-chars:0";
++ };
++
++};