aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-09-27 19:10:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-09-27 19:10:51 +0000
commit6918ea2484861cbf806c812b95a814ab40063c05 (patch)
tree3f4d53baabebad9339cadd1bbfaaf07ed61b9c1e /target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch
parentff6b0d57b8e4dd9c72b13ac0586c523c8d6e8841 (diff)
downloadupstream-6918ea2484861cbf806c812b95a814ab40063c05.tar.gz
upstream-6918ea2484861cbf806c812b95a814ab40063c05.tar.bz2
upstream-6918ea2484861cbf806c812b95a814ab40063c05.zip
brcm2708: update 3.10 patches with raspberrypi/rpi-3.10.y of 27 Apr. 2014
Update the 3.10 rasperry patches by rebasing raspberry/rpi-3.10-y against linux-stable/v3.10.49. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 42678
Diffstat (limited to 'target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch')
-rw-r--r--target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch b/target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch
index ee7c54b11b..7e41d38df8 100644
--- a/target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch
+++ b/target/linux/brcm2708/patches-3.10/0120-ASoC-Add-support-for-HifiBerry-DAC.patch
@@ -1,7 +1,7 @@
-From 584dfa04559ef74d7e862fd7319221f82efc1db0 Mon Sep 17 00:00:00 2001
+From ba93efdc28c5e66d5d01a1cd35c458aa1074d7d5 Mon Sep 17 00:00:00 2001
From: Florian Meier <florian.meier@koalo.de>
Date: Fri, 22 Nov 2013 19:19:08 +0100
-Subject: [PATCH 120/174] ASoC: Add support for HifiBerry DAC
+Subject: [PATCH 120/196] ASoC: Add support for HifiBerry DAC
This adds a machine driver for the HifiBerry DAC.
It is a sound card that can
@@ -15,6 +15,8 @@ Signed-off-by: Florian Meier <florian.meier@koalo.de>
3 files changed, 112 insertions(+)
create mode 100644 sound/soc/bcm/hifiberry_dac.c
+diff --git a/sound/soc/bcm/Kconfig b/sound/soc/bcm/Kconfig
+index 37c8f8c..8b14e37 100644
--- a/sound/soc/bcm/Kconfig
+++ b/sound/soc/bcm/Kconfig
@@ -8,3 +8,10 @@ config SND_BCM2708_SOC_I2S
@@ -28,6 +30,8 @@ Signed-off-by: Florian Meier <florian.meier@koalo.de>
+ select SND_SOC_PCM5102A
+ help
+ Say Y or M if you want to add support for HifiBerry DAC.
+diff --git a/sound/soc/bcm/Makefile b/sound/soc/bcm/Makefile
+index 486ea09..6834b4d 100644
--- a/sound/soc/bcm/Makefile
+++ b/sound/soc/bcm/Makefile
@@ -2,3 +2,8 @@
@@ -39,6 +43,9 @@ Signed-off-by: Florian Meier <florian.meier@koalo.de>
+snd-soc-hifiberry-dac-objs := hifiberry_dac.o
+
+obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
+diff --git a/sound/soc/bcm/hifiberry_dac.c b/sound/soc/bcm/hifiberry_dac.c
+new file mode 100644
+index 0000000..4b70b45
--- /dev/null
+++ b/sound/soc/bcm/hifiberry_dac.c
@@ -0,0 +1,100 @@
@@ -142,3 +149,6 @@ Signed-off-by: Florian Meier <florian.meier@koalo.de>
+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
+MODULE_DESCRIPTION("ASoC Driver for HifiBerry DAC");
+MODULE_LICENSE("GPL v2");
+--
+1.9.1
+