aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2017-02-08 00:38:21 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2017-02-08 00:41:51 +0100
commit7ef713c9c44a98965f1eac8afc4c706138aaa5ad (patch)
tree104b01fc252851863522a78cb8e99dad571ec76b /target/linux/brcm2708/image
parent77a00027c3b2172ee1779e298ebe206dde02b87a (diff)
downloadupstream-7ef713c9c44a98965f1eac8afc4c706138aaa5ad.tar.gz
upstream-7ef713c9c44a98965f1eac8afc4c706138aaa5ad.tar.bz2
upstream-7ef713c9c44a98965f1eac8afc4c706138aaa5ad.zip
brcm2708: bcm2710: add 64 bit support for Raspberry Pi 3
64 bit support for Raspberry Pi 3 is experimental. However, bcm2709 subtarget should serve as a stable and compatible 32 bit support. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 440408b4f7..dbe014565e 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -34,7 +34,7 @@ define Build/boot-img
mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
mcopy -i $@.boot cmdline.txt ::
mcopy -i $@.boot config.txt ::
- mcopy -i $@.boot $(IMAGE_KERNEL) ::kernel.img
+ mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
mmd -i $@.boot ::/overlays
mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
@@ -50,6 +50,7 @@ endef
define Device/Default
FILESYSTEMS := ext4
KERNEL := kernel-bin | kernel-img
+ KERNEL_IMG := kernel.img
IMAGES := sdcard.img
IMAGE/sdcard.img := boot-img | sdcard-img
endef
@@ -72,8 +73,9 @@ ifeq ($(SUBTARGET),bcm2709)
endif
define Device/rpi-3
- DEVICE_TITLE := Raspberry Pi 3 B/CM
- DEVICE_DTS := bcm2710-rpi-3-b bcm2710-rpi-cm3
+ KERNEL_IMG := kernel8.img
+ DEVICE_TITLE := Raspberry Pi 3B (64 bit)
+ DEVICE_DTS := broadcom/bcm2710-rpi-3-b
DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
endef
ifeq ($(SUBTARGET),bcm2710)