aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorChristo Nedev <christo.nedev@me.com>2018-04-26 16:10:15 +0000
committerJohn Crispin <john@phrozen.org>2018-04-27 09:59:33 +0200
commit50b09196282eff24e19541003dfcb248d616006e (patch)
treea1c4b18e0e53482d787c1ccf87faed09d9ad99c0 /target/linux/brcm2708/image
parent79126770868995faa8656f6687a88d385802e34b (diff)
downloadupstream-50b09196282eff24e19541003dfcb248d616006e.tar.gz
upstream-50b09196282eff24e19541003dfcb248d616006e.tar.bz2
upstream-50b09196282eff24e19541003dfcb248d616006e.zip
brcm2708: Add support for raspberry pi 3 b+.
Signed-off-by: Christo Nedev <christo.nedev@me.com>
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 9ea9a07a9d..691212de9f 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -64,9 +64,9 @@ ifeq ($(SUBTARGET),bcm2708)
endif
define Device/rpi-2
- DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
- DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
- SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,compute-module-3
+ DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
+ DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
+ SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,3-model-b-plus raspberrypi,compute-module-3
endef
ifeq ($(SUBTARGET),bcm2709)
TARGET_DEVICES += rpi-2
@@ -74,9 +74,9 @@ endif
define Device/rpi-3
KERNEL_IMG := kernel8.img
- DEVICE_TITLE := Raspberry Pi 3B (64 bit)
- DEVICE_DTS := broadcom/bcm2710-rpi-3-b
- SUPPORTED_DEVICES := rpi-3-b raspberrypi,3-model-b
+ DEVICE_TITLE := Raspberry Pi 3B/3B+
+ DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus
+ SUPPORTED_DEVICES := rpi-3-b rpi-3-b-plus raspberrypi,3-model-b raspberrypi,3-model-b-plus
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3