aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-05 10:27:34 +0000
committerJohn Crispin <john@openwrt.org>2015-10-05 10:27:34 +0000
commitb97498ab29089fd8318cabbcfbab25b263f552be (patch)
tree31d7de009f8bb51848a5f2f3b2d9ca655422206b /target/linux/brcm2708/image/Makefile
parenta32acfe73c0d5d0905d284b257d9155d35454df8 (diff)
downloadupstream-b97498ab29089fd8318cabbcfbab25b263f552be.tar.gz
upstream-b97498ab29089fd8318cabbcfbab25b263f552be.tar.bz2
upstream-b97498ab29089fd8318cabbcfbab25b263f552be.zip
brcm2708: switch device tree compilation to linux
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47124
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index de222f0801..7a68c506cf 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -22,10 +22,6 @@ else
endif
### Image scripts ###
-define Build/build-dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
-endef
-
define Build/gen-cfg
cat config.txt > $@.config
echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
@@ -44,7 +40,7 @@ define Build/boot-img
mcopy -i $@.boot cmdline.txt ::
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
- mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+ mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
endef
define Build/sdcard-img
@@ -59,7 +55,7 @@ define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
KERNEL := kernel-bin
IMAGES := sdcard.bin
- IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
+ IMAGE/sdcard.bin := gen-cfg | boot-img | sdcard-img
DEVICE_PROFILE :=
DEVICE_DTS :=
endef