aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-05 10:27:41 +0000
committerJohn Crispin <john@openwrt.org>2015-10-05 10:27:41 +0000
commitd1fc19265ab7f85c9a254a7c278069ef8a6ecfdb (patch)
tree837e8eea2e0d9ceeccdd39b7a8482542ca2c3e4c /target/linux/brcm2708/image/Makefile
parentb97498ab29089fd8318cabbcfbab25b263f552be (diff)
downloadupstream-d1fc19265ab7f85c9a254a7c278069ef8a6ecfdb.tar.gz
upstream-d1fc19265ab7f85c9a254a7c278069ef8a6ecfdb.tar.bz2
upstream-d1fc19265ab7f85c9a254a7c278069ef8a6ecfdb.zip
brcm2708: add support for device tree overlays
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47125
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 7a68c506cf..3744cace58 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -21,6 +21,12 @@ else
endef
endif
+define Image/Prepare
+ rm -rf $(KDIR)/overlays
+ mkdir -p $(KDIR)/overlays
+ $(CP) $(DTS_DIR)/overlays/*.dtb $(KDIR)/overlays/
+endef
+
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -41,6 +47,7 @@ define Build/boot-img
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
+ mcopy -s -i $@.boot $(KDIR)/overlays ::
endef
define Build/sdcard-img