aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-23 07:14:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-23 07:14:38 +0000
commitfcfb5c515a931d83c1637527df6f54532619c3c4 (patch)
treeb755a5bf98010489a49cbcc74c2236897e2aedb7 /target/linux/brcm2708/image/Makefile
parentcf0cf157401164d22422ec825e912afdb6f68418 (diff)
downloadupstream-fcfb5c515a931d83c1637527df6f54532619c3c4.tar.gz
upstream-fcfb5c515a931d83c1637527df6f54532619c3c4.tar.bz2
upstream-fcfb5c515a931d83c1637527df6f54532619c3c4.zip
CC: brcm2708: Add sysupgrade support for Raspberry Pi
Also create .gz images if configured to do so. This is equivalent, but different to what we have in trunk, as the image creation has been rewritten there. Signed-off-by: Bruno Randolf <br1@einfach.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47604 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index e70bdd04d8..633ed88005 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -28,6 +28,9 @@ define Image/Build/RaspberryPi
mcopy -i $(KDIR)/boot.img $(KDIR)/Image ::kernel.img # Copy OpenWrt built kernel
./gen_rpi_sdcard_img.sh $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img $(KDIR)/boot.img $(KDIR)/root.$(1) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ gzip -9n -c $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img > $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img.gz
+ endif
endef
define Image/Build