aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-24 20:39:17 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-24 20:39:17 +0000
commit259cad41cd82fcad082c9a892fa974e46b0f8d24 (patch)
tree6d38108969c18ba8fdad3cd124d7d4183adf2263 /target/linux/brcm2708/Makefile
parent68ca3cdc277f72f5f3ee99dd63fba93f8268f6fc (diff)
downloadupstream-259cad41cd82fcad082c9a892fa974e46b0f8d24.tar.gz
upstream-259cad41cd82fcad082c9a892fa974e46b0f8d24.tar.bz2
upstream-259cad41cd82fcad082c9a892fa974e46b0f8d24.zip
[brcm2708] adds target used by rapsberry pi
Add support for Raspberry Pi / brcm2708 / 2835 Signed-off-by: Ian Ridge <ianridge [at] gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32825 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/Makefile')
-rw-r--r--target/linux/brcm2708/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
new file mode 100644
index 0000000000..91207e979c
--- /dev/null
+++ b/target/linux/brcm2708/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host.mk
+
+ARCH:=arm
+BOARD:=brcm2708
+BOARDNAME:=Broadcom BCM2708/BCM2835
+FEATURES:=ext4 audio usb usbgadget display gpio
+MAINTAINER:=Ian Ridge <ianridge[at]gmail.com>
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
+
+define Target/Description
+ Build firmware image for Broadcom BCM2708/BCM2835 SoC devices.
+ Currently produces SD Card image for Raspberry Pi.
+endef
+
+CFLAGS:=-pipe -march=armv6 -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=softfp -marm
+
+$(eval $(call BuildTarget))