aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 02:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 02:30:36 +0000
commit2adf3524cf21365e61b9690565b93c6ccd5a57bf (patch)
treeaf3eeb879c6e3fd9a5706675a55b66993a0915c5 /target/linux/brcm-2.6/Makefile
parent4fb96c5db677ba6039ec373a1d4ed6562743bd6b (diff)
downloadupstream-2adf3524cf21365e61b9690565b93c6ccd5a57bf.tar.gz
upstream-2adf3524cf21365e61b9690565b93c6ccd5a57bf.tar.bz2
upstream-2adf3524cf21365e61b9690565b93c6ccd5a57bf.zip
add descriptions to the broadcom target profiles and export them to the target metadata (not presented in menuconfig yet)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6137 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm-2.6/Makefile')
-rw-r--r--target/linux/brcm-2.6/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/brcm-2.6/Makefile b/target/linux/brcm-2.6/Makefile
index 0a2575913d..0d5533194e 100644
--- a/target/linux/brcm-2.6/Makefile
+++ b/target/linux/brcm-2.6/Makefile
@@ -23,12 +23,20 @@ define Profile/Atheros
NAME:=Atheros WiFi (default)
PACKAGES:=kmod-madwifi
endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
$(eval $(call Profile,Atheros))
define Profile/None
NAME:=No WiFi
PACKAGES:=
endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
$(eval $(call Profile,None))
$(eval $(call BuildKernel))