aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 12:35:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 12:35:00 +0000
commit2fb06d46d9c5a8fc6158bf88f985743e60be3afb (patch)
treea219b0c6e587ba0b08a50cf43188eb3df401f888 /target/linux/brcm-2.4/Makefile
parent297f2368ba6d2aa7da2fcff19eae0e211720878e (diff)
downloadupstream-2fb06d46d9c5a8fc6158bf88f985743e60be3afb.tar.gz
upstream-2fb06d46d9c5a8fc6158bf88f985743e60be3afb.tar.bz2
upstream-2fb06d46d9c5a8fc6158bf88f985743e60be3afb.zip
Add WL-700gE support (based on work by jr) Includes kernel/diag patch and a new target profile
SVN-Revision: 6142
Diffstat (limited to 'target/linux/brcm-2.4/Makefile')
-rw-r--r--target/linux/brcm-2.4/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/Makefile b/target/linux/brcm-2.4/Makefile
index 0091360c73..28ee7b9205 100644
--- a/target/linux/brcm-2.4/Makefile
+++ b/target/linux/brcm-2.4/Makefile
@@ -112,4 +112,15 @@ define Profile/WLHDD/Description
endef
$(eval $(call Profile,WLHDD))
+define Profile/WL700GE
+ NAME:=WL-700gE
+ PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
+endef
+
+define Profile/WL700GE/Description
+ Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
+ and the utilities to create a new filesystem on the HDD
+endef
+$(eval $(call Profile,WL700GE))
+
$(eval $(call BuildKernel))