aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-20 10:05:52 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-23 12:18:35 +0200
commit7122609082e9826fa719b7445a600c88973c3b21 (patch)
tree98d20df8f05677791882d2a544727a6c7d58ec04 /target/linux/bmips
parente656bcbab0106aca52ec0b2db354c1336d39b3b3 (diff)
downloadupstream-7122609082e9826fa719b7445a600c88973c3b21.tar.gz
upstream-7122609082e9826fa719b7445a600c88973c3b21.tar.bz2
upstream-7122609082e9826fa719b7445a600c88973c3b21.zip
bmips: switch to generic bcma/ssb fallback SPROM
Stop using bmips b43-sprom fixups and switch to generic bcma/ssb fallback SPROMs. This way we don't need to include the b43-sprom fixups on devices without Broadcom wireless. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips')
-rw-r--r--target/linux/bmips/bcm6318/config-5.1510
-rw-r--r--target/linux/bmips/bcm63268/config-5.1510
-rw-r--r--target/linux/bmips/bcm6328/config-5.1510
-rw-r--r--target/linux/bmips/bcm6358/config-5.159
-rw-r--r--target/linux/bmips/bcm6362/config-5.1510
-rw-r--r--target/linux/bmips/bcm6368/config-5.159
-rw-r--r--target/linux/bmips/dts/bcm6318-comtrend-ar-5315u.dts3
-rw-r--r--target/linux/bmips/dts/bcm6328-comtrend-ar-5387un.dts3
-rw-r--r--target/linux/bmips/dts/bcm6368-comtrend-vr-3025u.dts3
-rw-r--r--target/linux/bmips/image/bcm6318.mk3
-rw-r--r--target/linux/bmips/image/bcm6328.mk3
-rw-r--r--target/linux/bmips/image/bcm6368.mk3
12 files changed, 12 insertions, 64 deletions
diff --git a/target/linux/bmips/bcm6318/config-5.15 b/target/linux/bmips/bcm6318/config-5.15
index 588d751744..50401a58e8 100644
--- a/target/linux/bmips/bcm6318/config-5.15
+++ b/target/linux/bmips/bcm6318/config-5.15
@@ -14,16 +14,6 @@ CONFIG_BCM6345_L1_IRQ=y
CONFIG_BCM6368_ENETSW=y
CONFIG_BCM63XX_POWER=y
CONFIG_BCM7038_WDT=y
-CONFIG_BCMA=y
-CONFIG_BCMA_BLOCKIO=y
-# CONFIG_BCMA_DEBUG is not set
-# CONFIG_BCMA_DRIVER_GMAC_CMN is not set
-# CONFIG_BCMA_DRIVER_MIPS is not set
-CONFIG_BCMA_DRIVER_PCI=y
-# CONFIG_BCMA_DRIVER_PCI_HOSTMODE is not set
-CONFIG_BCMA_HOST_PCI=y
-CONFIG_BCMA_HOST_PCI_POSSIBLE=y
-# CONFIG_BCMA_HOST_SOC is not set
CONFIG_BLK_MQ_PCI=y
CONFIG_BLK_PM=y
CONFIG_BMIPS_GENERIC=y
diff --git a/target/linux/bmips/bcm63268/config-5.15 b/target/linux/bmips/bcm63268/config-5.15
index 4cdbe13228..09754e9f8b 100644
--- a/target/linux/bmips/bcm63268/config-5.15
+++ b/target/linux/bmips/bcm63268/config-5.15
@@ -14,16 +14,6 @@ CONFIG_BCM6345_L1_IRQ=y
CONFIG_BCM6368_ENETSW=y
CONFIG_BCM63XX_POWER=y
CONFIG_BCM7038_WDT=y
-CONFIG_BCMA=y
-CONFIG_BCMA_BLOCKIO=y
-# CONFIG_BCMA_DEBUG is not set
-# CONFIG_BCMA_DRIVER_GMAC_CMN is not set
-# CONFIG_BCMA_DRIVER_MIPS is not set
-CONFIG_BCMA_DRIVER_PCI=y
-# CONFIG_BCMA_DRIVER_PCI_HOSTMODE is not set
-CONFIG_BCMA_HOST_PCI=y
-CONFIG_BCMA_HOST_PCI_POSSIBLE=y
-# CONFIG_BCMA_HOST_SOC is not set
CONFIG_BLK_MQ_PCI=y
CONFIG_BLK_PM=y
CONFIG_BMIPS_GENERIC=y
diff --git a/target/linux/bmips/bcm6328/config-5.15 b/target/linux/bmips/bcm6328/config-5.15
index ea9898782a..1e7712ead6 100644
--- a/target/linux/bmips/bcm6328/config-5.15
+++ b/target/linux/bmips/bcm6328/config-5.15
@@ -14,16 +14,6 @@ CONFIG_BCM6345_L1_IRQ=y
CONFIG_BCM6368_ENETSW=y
CONFIG_BCM63XX_POWER=y
CONFIG_BCM7038_WDT=y
-CONFIG_BCMA=y
-CONFIG_BCMA_BLOCKIO=y
-# CONFIG_BCMA_DEBUG is not set
-# CONFIG_BCMA_DRIVER_GMAC_CMN is not set
-# CONFIG_BCMA_DRIVER_MIPS is not set
-CONFIG_BCMA_DRIVER_PCI=y
-# CONFIG_BCMA_DRIVER_PCI_HOSTMODE is not set
-CONFIG_BCMA_HOST_PCI=y
-CONFIG_BCMA_HOST_PCI_POSSIBLE=y
-# CONFIG_BCMA_HOST_SOC is not set
CONFIG_BLK_MQ_PCI=y
CONFIG_BLK_PM=y
CONFIG_BMIPS_GENERIC=y
diff --git a/target/linux/bmips/bcm6358/config-5.15 b/target/linux/bmips/bcm6358/config-5.15
index 62956398d5..5d7a299444 100644
--- a/target/linux/bmips/bcm6358/config-5.15
+++ b/target/linux/bmips/bcm6358/config-5.15
@@ -230,15 +230,6 @@ CONFIG_SPI_BCM63XX=y
CONFIG_SPI_MASTER=y
CONFIG_SPI_MEM=y
CONFIG_SRCU=y
-CONFIG_SSB=y
-CONFIG_SSB_B43_PCI_BRIDGE=y
-CONFIG_SSB_BLOCKIO=y
-# CONFIG_SSB_DRIVER_MIPS is not set
-CONFIG_SSB_DRIVER_PCICORE=y
-CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y
-CONFIG_SSB_PCIHOST=y
-CONFIG_SSB_PCIHOST_POSSIBLE=y
-CONFIG_SSB_SPROM=y
CONFIG_SWAP_IO_SPACE=y
CONFIG_SWPHY=y
CONFIG_SYNC_R4K=y
diff --git a/target/linux/bmips/bcm6362/config-5.15 b/target/linux/bmips/bcm6362/config-5.15
index 325692e5f3..5f9b528d95 100644
--- a/target/linux/bmips/bcm6362/config-5.15
+++ b/target/linux/bmips/bcm6362/config-5.15
@@ -14,16 +14,6 @@ CONFIG_BCM6345_L1_IRQ=y
CONFIG_BCM6368_ENETSW=y
CONFIG_BCM63XX_POWER=y
CONFIG_BCM7038_WDT=y
-CONFIG_BCMA=y
-CONFIG_BCMA_BLOCKIO=y
-# CONFIG_BCMA_DEBUG is not set
-# CONFIG_BCMA_DRIVER_GMAC_CMN is not set
-# CONFIG_BCMA_DRIVER_MIPS is not set
-CONFIG_BCMA_DRIVER_PCI=y
-# CONFIG_BCMA_DRIVER_PCI_HOSTMODE is not set
-CONFIG_BCMA_HOST_PCI=y
-CONFIG_BCMA_HOST_PCI_POSSIBLE=y
-# CONFIG_BCMA_HOST_SOC is not set
CONFIG_BLK_MQ_PCI=y
CONFIG_BLK_PM=y
CONFIG_BMIPS_GENERIC=y
diff --git a/target/linux/bmips/bcm6368/config-5.15 b/target/linux/bmips/bcm6368/config-5.15
index 06d72d9ebe..910d36ce0b 100644
--- a/target/linux/bmips/bcm6368/config-5.15
+++ b/target/linux/bmips/bcm6368/config-5.15
@@ -245,15 +245,6 @@ CONFIG_SPI_BCM63XX=y
CONFIG_SPI_MASTER=y
CONFIG_SPI_MEM=y
CONFIG_SRCU=y
-CONFIG_SSB=y
-CONFIG_SSB_B43_PCI_BRIDGE=y
-CONFIG_SSB_BLOCKIO=y
-# CONFIG_SSB_DRIVER_MIPS is not set
-CONFIG_SSB_DRIVER_PCICORE=y
-CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y
-CONFIG_SSB_PCIHOST=y
-CONFIG_SSB_PCIHOST_POSSIBLE=y
-CONFIG_SSB_SPROM=y
CONFIG_SWAP_IO_SPACE=y
CONFIG_SWPHY=y
CONFIG_SYNC_R4K=y
diff --git a/target/linux/bmips/dts/bcm6318-comtrend-ar-5315u.dts b/target/linux/bmips/dts/bcm6318-comtrend-ar-5315u.dts
index 9226922a7a..7f2d438efb 100644
--- a/target/linux/bmips/dts/bcm6318-comtrend-ar-5315u.dts
+++ b/target/linux/bmips/dts/bcm6318-comtrend-ar-5315u.dts
@@ -37,7 +37,7 @@
};
bcm43217-sprom {
- compatible = "brcm,bcm43217-sprom";
+ compatible = "brcm,bcma-sprom";
pci-bus = <1>;
pci-dev = <0>;
@@ -46,6 +46,7 @@
nvmem-cell-names = "mac-address";
mac-address-increment = <1>;
+ brcm,sprom = "brcm/bcm43217-sprom.bin";
brcm,sprom-fixups = <6 0x1c00>,
<65 0x1255>,
<97 0xfe55>,
diff --git a/target/linux/bmips/dts/bcm6328-comtrend-ar-5387un.dts b/target/linux/bmips/dts/bcm6328-comtrend-ar-5387un.dts
index df6ee5eadd..276858dff7 100644
--- a/target/linux/bmips/dts/bcm6328-comtrend-ar-5387un.dts
+++ b/target/linux/bmips/dts/bcm6328-comtrend-ar-5387un.dts
@@ -29,7 +29,7 @@
};
bcm43225-sprom {
- compatible = "brcm,bcm43225-sprom";
+ compatible = "brcm,bcma-sprom";
pci-bus = <1>;
pci-dev = <0>;
@@ -38,6 +38,7 @@
nvmem-cell-names = "mac-address";
mac-address-increment = <1>;
+ brcm,sprom = "brcm/bcm43225-sprom.bin";
brcm,sprom-fixups = <2 0x05bb>,
<65 0x1204>,
<78 0x0303>,
diff --git a/target/linux/bmips/dts/bcm6368-comtrend-vr-3025u.dts b/target/linux/bmips/dts/bcm6368-comtrend-vr-3025u.dts
index 5f0565fa4c..b29078d645 100644
--- a/target/linux/bmips/dts/bcm6368-comtrend-vr-3025u.dts
+++ b/target/linux/bmips/dts/bcm6368-comtrend-vr-3025u.dts
@@ -58,7 +58,7 @@
};
bcm43222-sprom {
- compatible = "brcm,bcm43222-sprom";
+ compatible = "brcm,ssb-sprom";
pci-bus = <0>;
pci-dev = <1>;
@@ -67,6 +67,7 @@
nvmem-cell-names = "mac-address";
mac-address-increment = <1>;
+ brcm,sprom = "brcm/bcm43222-sprom.bin";
brcm,sprom-fixups = <97 0xfeb3>,
<98 0x1618>,
<99 0xfab0>,
diff --git a/target/linux/bmips/image/bcm6318.mk b/target/linux/bmips/image/bcm6318.mk
index fc73eb4521..bfd75cc077 100644
--- a/target/linux/bmips/image/bcm6318.mk
+++ b/target/linux/bmips/image/bcm6318.mk
@@ -7,7 +7,8 @@ define Device/comtrend_ar-5315u
CHIP_ID := 6318
CFE_BOARD_ID := 96318A-1441N1
FLASH_MB := 16
- DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43217-sprom \
kmod-leds-bcm6328
endef
TARGET_DEVICES += comtrend_ar-5315u
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
index 3a739a7e71..b3cef51a71 100644
--- a/target/linux/bmips/image/bcm6328.mk
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -7,7 +7,8 @@ define Device/comtrend_ar-5387un
CHIP_ID := 6328
CFE_BOARD_ID := 96328A-1441N1
FLASH_MB := 16
- DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43225-sprom \
kmod-leds-bcm6328
endef
TARGET_DEVICES += comtrend_ar-5387un
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index be4cc576db..268b68dd7c 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -8,7 +8,8 @@ define Device/comtrend_vr-3025u
CFE_BOARD_ID := 96368M-1541N
BLOCKSIZE := 0x20000
FLASH_MB := 32
- DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43222-sprom \
kmod-leds-gpio
endef
TARGET_DEVICES += comtrend_vr-3025u