aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-23 11:44:34 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-23 12:19:02 +0200
commit3132eff0007f20d5f9d8d7f40214962c2b4942d5 (patch)
treef3fab2997e88cd39ff57cb090fe0a04f4d880e1d /target/linux/bmips
parent0cecebd413e52b4c59745c8c42b7a9ca2b11bdbf (diff)
downloadupstream-3132eff0007f20d5f9d8d7f40214962c2b4942d5.tar.gz
upstream-3132eff0007f20d5f9d8d7f40214962c2b4942d5.tar.bz2
upstream-3132eff0007f20d5f9d8d7f40214962c2b4942d5.zip
bmips: shg2500: add BCM4360 fallback SPROM
Apart from the embedded BCM63268 wireless, this device has an external BCM4360 connected by PCIe which needs a fallback SPROM. b43 isn't enabled for this device because BCM4360 isn't supported (AC PHY). Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips')
-rw-r--r--target/linux/bmips/dts/bcm63168-sercomm-shg2500.dts13
-rw-r--r--target/linux/bmips/image/bcm63268.mk5
2 files changed, 16 insertions, 2 deletions
diff --git a/target/linux/bmips/dts/bcm63168-sercomm-shg2500.dts b/target/linux/bmips/dts/bcm63168-sercomm-shg2500.dts
index 76bedfac94..bcab940771 100644
--- a/target/linux/bmips/dts/bcm63168-sercomm-shg2500.dts
+++ b/target/linux/bmips/dts/bcm63168-sercomm-shg2500.dts
@@ -43,6 +43,19 @@
debounce-interval = <60>;
};
};
+
+ bcm4360-sprom {
+ compatible = "brcm,bcma-sprom";
+
+ pci-bus = <1>;
+ pci-dev = <0>;
+
+ nvmem-cells = <&macaddr_cferom_6a0>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <1>;
+
+ brcm,sprom = "brcm/bcm4360-sprom.bin";
+ };
};
&ehci {
diff --git a/target/linux/bmips/image/bcm63268.mk b/target/linux/bmips/image/bcm63268.mk
index 6f7cda7405..6e27b16624 100644
--- a/target/linux/bmips/image/bcm63268.mk
+++ b/target/linux/bmips/image/bcm63268.mk
@@ -73,8 +73,9 @@ define Device/sercomm_shg2500
PAGESIZE := 2048
SUBPAGESIZE := 512
VID_HDR_OFFSET := 2048
- DEVICE_PACKAGES += $(USB2_PACKAGES) kmod-i2c-gpio \
- kmod-leds-sercomm-msp430
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ broadcom-4360-sprom \
+ kmod-i2c-gpio kmod-leds-sercomm-msp430
SERCOMM_FSVER := 1001
SERCOMM_HWVER := 1424e4a
SERCOMM_SWVER := 3207