aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 10:06:26 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 10:06:26 +0200
commitd309160d301a5530a4db3938ee287886555c1b3b (patch)
treedc558530a40ea490a4fca03054e3af35fb0a0a9a /target/linux/bmips
parent0cdc257b8d371e85133b7f463785785fe5f0aee3 (diff)
downloadupstream-d309160d301a5530a4db3938ee287886555c1b3b.tar.gz
upstream-d309160d301a5530a4db3938ee287886555c1b3b.tar.bz2
upstream-d309160d301a5530a4db3938ee287886555c1b3b.zip
bmips: image: rename SERCOMM_VERSION to SERCOMM_FSVER
SERCOMM_VERSION is ambiguous and it should be more clear that it refers to the version used for the filesystem. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips')
-rw-r--r--target/linux/bmips/image/Makefile6
-rw-r--r--target/linux/bmips/image/bcm63xx_nand.mk8
2 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/bmips/image/Makefile b/target/linux/bmips/image/Makefile
index af2fd98d1f..907779847d 100644
--- a/target/linux/bmips/image/Makefile
+++ b/target/linux/bmips/image/Makefile
@@ -208,18 +208,18 @@ define Build/cfe-sercomm-part
--output-file $@.kernel_rootfs \
--part-name kernel_rootfs \
--part-version OpenWrt \
- --rootfs-version $(SERCOMM_VERSION)
+ --rootfs-version $(SERCOMM_FSVER)
rm -rf $@-rootfs_lib
mkdir -p $@-rootfs_lib
- echo $(SERCOMM_VERSION) > $@-rootfs_lib/lib_ver
+ echo $(SERCOMM_FSVER) > $@-rootfs_lib/lib_ver
$(call Build/cfe-jffs2,$@-rootfs_lib)
$(call Build/pad-to,$(BLOCKSIZE))
$(TOPDIR)/scripts/sercomm-partition-tag.py \
--input-file $@ \
--output-file $@.rootfs_lib \
--part-name rootfs_lib \
- --part-version $(SERCOMM_VERSION)
+ --part-version $(SERCOMM_FSVER)
mv $@.kernel_rootfs $@
dd if=$@.rootfs_lib >> $@
diff --git a/target/linux/bmips/image/bcm63xx_nand.mk b/target/linux/bmips/image/bcm63xx_nand.mk
index 01540625ed..b8be3016c9 100644
--- a/target/linux/bmips/image/bcm63xx_nand.mk
+++ b/target/linux/bmips/image/bcm63xx_nand.mk
@@ -5,7 +5,7 @@ DEVICE_VARS += CFE_RAM_FILE
DEVICE_VARS += CFE_RAM_JFFS2_NAME CFE_RAM_JFFS2_PAD
DEVICE_VARS += CFE_WFI_CHIP_ID CFE_WFI_FLASH_TYPE
DEVICE_VARS += CFE_WFI_FLAGS CFE_WFI_VERSION
-DEVICE_VARS += SERCOMM_PID SERCOMM_VERSION
+DEVICE_VARS += SERCOMM_PID SERCOMM_FSVER
# CFE expects a single JFFS2 partition with cferam and kernel. However,
# it's possible to fool CFE into properly loading both cferam and kernel
@@ -42,7 +42,7 @@ define Device/sercomm-nand
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi |\
cfe-sercomm-part | gzip | cfe-sercomm-load | cfe-sercomm-crypto
SERCOM_PID :=
- SERCOMM_VERSION :=
+ SERCOMM_FSVER :=
endef
define Device/comtrend_vr-3032u
@@ -124,7 +124,7 @@ define Device/sercomm_h500-s-lowi
30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
30 30 30 30 33 33 30 35 30 30 30 30 30 30 30 30 \
0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
- SERCOMM_VERSION := 1001
+ SERCOMM_FSVER := 1001
endef
TARGET_DEVICES += sercomm_h500-s-lowi
@@ -151,6 +151,6 @@ define Device/sercomm_h500-s-vfes
30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
30 30 30 30 33 34 31 37 30 30 30 30 30 30 30 30 \
0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
- SERCOMM_VERSION := 1001
+ SERCOMM_FSVER := 1001
endef
TARGET_DEVICES += sercomm_h500-s-vfes