aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2022-05-18 22:52:06 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2022-05-20 12:21:03 +0200
commit6a1e7c767f197b80385f4be9ac7a4b5af27cb4ec (patch)
tree61c2f6077baf9dbdc058815d49c5f211984a3f4f /target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch
parent810eac8c7ffad958345f8fd02f83636afecf7fcd (diff)
downloadupstream-6a1e7c767f197b80385f4be9ac7a4b5af27cb4ec.tar.gz
upstream-6a1e7c767f197b80385f4be9ac7a4b5af27cb4ec.tar.bz2
upstream-6a1e7c767f197b80385f4be9ac7a4b5af27cb4ec.zip
bmips: add linux v5.15 support
Build system: x86_64 Build-tested: generic, nand Run-tested: generic/AR-5387un, nand/VR-3032u Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch')
-rw-r--r--target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch b/target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch
new file mode 100644
index 0000000000..c0572604ee
--- /dev/null
+++ b/target/linux/bmips/patches-5.15/603-pci-controllers-add-bcm6348-pci-support.patch
@@ -0,0 +1,22 @@
+--- a/drivers/pci/controller/Kconfig
++++ b/drivers/pci/controller/Kconfig
+@@ -3,6 +3,11 @@
+ menu "PCI controller drivers"
+ depends on PCI
+
++config PCI_BCM6348
++ bool "BCM6348 PCI controller"
++ depends on BMIPS_GENERIC || COMPILE_TEST
++ depends on OF
++
+ config PCIE_BCM6318
+ bool "BCM6318 PCIe controller"
+ depends on BMIPS_GENERIC || COMPILE_TEST
+--- a/drivers/pci/controller/Makefile
++++ b/drivers/pci/controller/Makefile
+@@ -1,4 +1,5 @@
+ # SPDX-License-Identifier: GPL-2.0
++obj-$(CONFIG_PCI_BCM6348) += pci-bcm6348.o
+ obj-$(CONFIG_PCIE_BCM6318) += pcie-bcm6318.o
+ obj-$(CONFIG_PCIE_BCM6328) += pcie-bcm6328.o
+ obj-$(CONFIG_PCIE_CADENCE) += cadence/