aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/modules.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-30 23:14:13 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 10:33:13 +0200
commitaefeb34223022c65ea0e7eef49c6c39250afd4ea (patch)
tree35a8a86da05499acbcdbbacd9729fb744732b470 /target/linux/bmips/modules.mk
parentd11a7c4d95a5ecbd2b12750be63349a3d0da2d53 (diff)
downloadupstream-aefeb34223022c65ea0e7eef49c6c39250afd4ea.tar.gz
upstream-aefeb34223022c65ea0e7eef49c6c39250afd4ea.tar.bz2
upstream-aefeb34223022c65ea0e7eef49c6c39250afd4ea.zip
bmips: add support for Sercomm SHG2500
Sercomm SHG2500 is a BCM63168 with 128M of RAM, 256M of NAND, an external BCM53124S switch for the LAN ports and internal/external Broadcom wifi. LEDs are connected to an external MSP430G2513 MCU controlled via SPI. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/modules.mk')
-rw-r--r--target/linux/bmips/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/bmips/modules.mk b/target/linux/bmips/modules.mk
new file mode 100644
index 0000000000..8f4b344357
--- /dev/null
+++ b/target/linux/bmips/modules.mk
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+define KernelPackage/leds-sercomm-msp430
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Sercomm MSP430G2513 LED support
+ KCONFIG:=CONFIG_LEDS_SERCOMM_MSP430
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-sercomm-msp430.ko
+ DEPENDS:=@TARGET_bmips +kmod-ledtrig-pattern
+ AUTOLOAD:=$(call AutoLoad,60,leds-sercomm-msp430,1)
+endef
+
+define KernelPackage/leds-sercomm-msp430/description
+ Kernel support for the Sercomm MSP430G2513 SPI LED controller.
+endef
+
+$(eval $(call KernelPackage,leds-sercomm-msp430))