aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2023-06-10 11:54:59 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-10 15:42:35 +0200
commitf25afae0b51c47a185ae30d4414ce229f27feb8e (patch)
treef918e91c25ac20623728d6dbde2c4819ec4cff21 /target/linux/bmips/image
parent725319ad3857e0d6b2f5f900e9ab2f779ad53410 (diff)
downloadupstream-f25afae0b51c47a185ae30d4414ce229f27feb8e.tar.gz
upstream-f25afae0b51c47a185ae30d4414ce229f27feb8e.tar.bz2
upstream-f25afae0b51c47a185ae30d4414ce229f27feb8e.zip
bmips: add support for Netgear DGND3700 v1, DGND3800B
The Netgear DGND3700 v1 and DGND3800B are the same device but with different factory firmwares. It's an xDSL wifi router with a slim black shiny casing and 4 PCB internal antennas connected via UFL to a miniPCI detachable card. Hardware: - SoC: Broadcom BCM6368 - CPU: dual core BMIPS4350 V3.1 @400Mhz - RAM: 128 MB DDR - NOR Flash: 32 MB parallel (CFE and OS) - NAND flash: 128 MB (empty) - Ethernet LAN: 5x 1Gbit - Wifi 2.4 GHz: Broadcom BCM43222 802.11bgn - Wifi 5 GHz: Broadcom BCM43222 802.11abgn - USB: 2x 2.0 - Buttons: 3x, 1 reset - LEDs: 11x - UART: yes Installation via OEM web UI: 1. Open the Netgear administration web interface, by default: http://192.168.0.1 user: admin password: password 2. Look for "upgrade firmware" and proceed 3. Wait some minutes until it finishes Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/bmips/image')
-rw-r--r--target/linux/bmips/image/Makefile9
-rw-r--r--target/linux/bmips/image/bcm6368.mk29
2 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/bmips/image/Makefile b/target/linux/bmips/image/Makefile
index b5e3098fe7..58685dec74 100644
--- a/target/linux/bmips/image/Makefile
+++ b/target/linux/bmips/image/Makefile
@@ -313,6 +313,15 @@ define Device/bcm63xx-nand
DEVICE_PACKAGES += nand-utils
endef
+define Device/bcm63xx_netgear
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := NETGEAR
+ IMAGES := factory.chk sysupgrade.bin
+ IMAGE/factory.chk := cfe-bin | netgear-chk
+ NETGEAR_BOARD_ID :=
+ NETGEAR_REGION :=
+endef
+
define Device/sercomm-nand
$(Device/bcm63xx-nand)
IMAGES := factory.img sysupgrade.bin
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index e3aa40d404..41bce9e938 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -14,6 +14,35 @@ define Device/comtrend_vr-3025u
endef
TARGET_DEVICES += comtrend_vr-3025u
+define Device/netgear_dgnd3700-v1
+ $(Device/bcm63xx_netgear)
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := DGND3700
+ DEVICE_VARIANT := v1
+ CFE_BOARD_ID := 96368MVWG
+ CHIP_ID := 6368
+ BLOCKSIZE := 0x20000
+ NETGEAR_BOARD_ID := U12L144T01_NETGEAR_NEWLED
+ NETGEAR_REGION := 1
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES)
+endef
+TARGET_DEVICES += netgear_dgnd3700-v1
+
+define Device/netgear_dgnd3800b
+ $(Device/bcm63xx_netgear)
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := DGND3800B
+ CFE_BOARD_ID := 96368MVWG
+ CHIP_ID := 6368
+ BLOCKSIZE := 0x20000
+ NETGEAR_BOARD_ID := U12L144T11_NETGEAR_NEWLED
+ NETGEAR_REGION := 1
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES)
+endef
+TARGET_DEVICES += netgear_dgnd3800b
+
define Device/observa_vh4032n
$(Device/bcm63xx-cfe)
DEVICE_VENDOR := Observa