aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-30 23:14:13 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 10:33:13 +0200
commitaefeb34223022c65ea0e7eef49c6c39250afd4ea (patch)
tree35a8a86da05499acbcdbbacd9729fb744732b470 /target/linux/bmips/image
parentd11a7c4d95a5ecbd2b12750be63349a3d0da2d53 (diff)
downloadupstream-aefeb34223022c65ea0e7eef49c6c39250afd4ea.tar.gz
upstream-aefeb34223022c65ea0e7eef49c6c39250afd4ea.tar.bz2
upstream-aefeb34223022c65ea0e7eef49c6c39250afd4ea.zip
bmips: add support for Sercomm SHG2500
Sercomm SHG2500 is a BCM63168 with 128M of RAM, 256M of NAND, an external BCM53124S switch for the LAN ports and internal/external Broadcom wifi. LEDs are connected to an external MSP430G2513 MCU controlled via SPI. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/image')
-rw-r--r--target/linux/bmips/image/bcm63xx_nand.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm63xx_nand.mk b/target/linux/bmips/image/bcm63xx_nand.mk
index 89b634c8d1..faed7a0919 100644
--- a/target/linux/bmips/image/bcm63xx_nand.mk
+++ b/target/linux/bmips/image/bcm63xx_nand.mk
@@ -141,3 +141,23 @@ define Device/sercomm_h500-s-vfes
SERCOMM_SWVER := 3417
endef
TARGET_DEVICES += sercomm_h500-s-vfes
+
+define Device/sercomm_shg2500
+ $(Device/sercomm-nand)
+ DEVICE_VENDOR := Sercomm
+ DEVICE_MODEL := SHG2500
+ DEVICE_LOADADDR := $(KERNEL_LOADADDR)
+ KERNEL := kernel-bin | append-dtb | lzma | cfe-jffs2-kernel
+ CHIP_ID := 63268
+ SOC := bcm63168
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES) kmod-i2c-gpio \
+ kmod-leds-sercomm-msp430
+ SERCOMM_FSVER := 1001
+ SERCOMM_HWVER := 1424e4a
+ SERCOMM_SWVER := 3207
+endef
+TARGET_DEVICES += sercomm_shg2500