aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-20 10:05:52 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-23 12:18:35 +0200
commit7122609082e9826fa719b7445a600c88973c3b21 (patch)
tree98d20df8f05677791882d2a544727a6c7d58ec04 /target/linux/bmips/image
parente656bcbab0106aca52ec0b2db354c1336d39b3b3 (diff)
downloadupstream-7122609082e9826fa719b7445a600c88973c3b21.tar.gz
upstream-7122609082e9826fa719b7445a600c88973c3b21.tar.bz2
upstream-7122609082e9826fa719b7445a600c88973c3b21.zip
bmips: switch to generic bcma/ssb fallback SPROM
Stop using bmips b43-sprom fixups and switch to generic bcma/ssb fallback SPROMs. This way we don't need to include the b43-sprom fixups on devices without Broadcom wireless. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/image')
-rw-r--r--target/linux/bmips/image/bcm6318.mk3
-rw-r--r--target/linux/bmips/image/bcm6328.mk3
-rw-r--r--target/linux/bmips/image/bcm6368.mk3
3 files changed, 6 insertions, 3 deletions
diff --git a/target/linux/bmips/image/bcm6318.mk b/target/linux/bmips/image/bcm6318.mk
index fc73eb4521..bfd75cc077 100644
--- a/target/linux/bmips/image/bcm6318.mk
+++ b/target/linux/bmips/image/bcm6318.mk
@@ -7,7 +7,8 @@ define Device/comtrend_ar-5315u
CHIP_ID := 6318
CFE_BOARD_ID := 96318A-1441N1
FLASH_MB := 16
- DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43217-sprom \
kmod-leds-bcm6328
endef
TARGET_DEVICES += comtrend_ar-5315u
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
index 3a739a7e71..b3cef51a71 100644
--- a/target/linux/bmips/image/bcm6328.mk
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -7,7 +7,8 @@ define Device/comtrend_ar-5387un
CHIP_ID := 6328
CFE_BOARD_ID := 96328A-1441N1
FLASH_MB := 16
- DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43225-sprom \
kmod-leds-bcm6328
endef
TARGET_DEVICES += comtrend_ar-5387un
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index be4cc576db..268b68dd7c 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -8,7 +8,8 @@ define Device/comtrend_vr-3025u
CFE_BOARD_ID := 96368M-1541N
BLOCKSIZE := 0x20000
FLASH_MB := 32
- DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43222-sprom \
kmod-leds-gpio
endef
TARGET_DEVICES += comtrend_vr-3025u