aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-11 12:30:57 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-11 18:33:33 +0200
commitcfdcf4b4d91006ae2202f9846df3a8d23fe098a2 (patch)
treed0b972f82bf4cec656adf02ba0e3f5b196025b10 /target/linux/bmips/image
parent8b20b8fe2ab2b67463c9a725627ac6951da6750c (diff)
downloadupstream-cfdcf4b4d91006ae2202f9846df3a8d23fe098a2.tar.gz
upstream-cfdcf4b4d91006ae2202f9846df3a8d23fe098a2.tar.bz2
upstream-cfdcf4b4d91006ae2202f9846df3a8d23fe098a2.zip
bmips: add support for Comtrend WAP-5813n
The Comtrend WAP-5813n is a wifi gigabit router, 2.4 GHz single band with two external antennas. Hardware: - SoC: Broadcom BCM6369 - CPU: dual core BMIPS4350 @ 400Mhz - RAM: 64 MB DDR - Flash: 8 MB parallel NOR - LAN switch: Broadcom BCM53115, 5x 1Gbit - Wifi 2.4 GHz: miniPCI Broadcom BCM4322 802.11bgn - USB: 1x 2.0 (optional) - Buttons: 3x (reset) - LEDs: yes - UART: yes Installation via CFE web UI: 1. Power off the router. 2. Press reset button near the power switch. 3. Keep it pressed while powering up during ~20+ seconds. 4. Browse to http://192.168.1.1 and upload the firmware. 5. Wait a few minutes for it to finish. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> (cherry picked from commit c3b1ef2dfd)
Diffstat (limited to 'target/linux/bmips/image')
-rw-r--r--target/linux/bmips/image/bcm6368.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index 67f8bbb09f..83cd096959 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -27,6 +27,20 @@ define Device/comtrend_vr-3025un
endef
TARGET_DEVICES += comtrend_vr-3025un
+define Device/comtrend_wap-5813n
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := Comtrend
+ DEVICE_MODEL := WAP-5813n
+ CHIP_ID := 6368
+ SOC := bcm6369
+ CFE_BOARD_ID := 96369R-1231N
+ FLASH_MB := 8
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-4322-sprom \
+ kmod-leds-gpio
+endef
+TARGET_DEVICES += comtrend_wap-5813n
+
define Device/netgear_dgnd3700-v1
$(Device/bcm63xx-netgear)
DEVICE_VENDOR := NETGEAR