aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6368.mk
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2023-06-13 22:45:53 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-15 18:01:20 +0200
commit40966d612efa6fb7909b9ae2140c2fd9d37f331e (patch)
treed70a089d1e549377f83c4cf7fc2ed73ea26332bd /target/linux/bmips/image/bcm6368.mk
parente6acfe03dd0c5afdfeeff2826ebb2258b43fe8d9 (diff)
downloadupstream-40966d612efa6fb7909b9ae2140c2fd9d37f331e.tar.gz
upstream-40966d612efa6fb7909b9ae2140c2fd9d37f331e.tar.bz2
upstream-40966d612efa6fb7909b9ae2140c2fd9d37f331e.zip
bmips: add support for Actiontec R1000H
The Actiontec R1000H is a gigabit wifi router, 2.4 GHz single band with two external antennas. It comes with a coaxial HomePNA port. Hardware: - SoC: Broadcom BCM6368 - CPU: dual core BMIPS4350 V3.1 @400Mhz - RAM: 64 MB DDR - Flash: 32 MB parallel NOR - LAN switch: Broadcom BCM53115, 5x 1Gbit - LAN coaxial : 1x HPNA 3.1, CG3211 + CG3213 - Wifi 2.4 GHz: Broadcom BCM4322 802.11bgn - USB: 1x 2.0 - Buttons: 2x, 1 reset - LEDs: 7x - UART: yes The HPNA hardware probably needs a firmware to make the coaxial port work. In the OEM firmware, it's apparently sent with an utility (inhpna) through the ethernet port. Installation via CFE web UI: 1. Connect the UART serial port. 2. Power on the router and press enter at the console prompt to stop the bootloader. 4. Browse to http://192.168.1.1 and upload the OpenWrt CFE firmware 5. Wait a few minutes for it to finish Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com> (cherry picked from commit e1a55de7a7eafd40a4fab5f29153a1a3c3606818)
Diffstat (limited to 'target/linux/bmips/image/bcm6368.mk')
-rw-r--r--target/linux/bmips/image/bcm6368.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index 83cd096959..39fcb02318 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -1,5 +1,20 @@
# SPDX-License-Identifier: GPL-2.0-or-later
+define Device/actiontec_r1000h
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := Actiontec
+ DEVICE_MODEL := R1000H
+ CHIP_ID := 6368
+ CFE_BOARD_ID := 96368VVW
+ BLOCKSIZE := 0x20000
+ FLASH_MB := 32
+ CFE_EXTRAS += --signature "$$(DEVICE_VENDOR)"
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) \
+ kmod-leds-gpio
+endef
+TARGET_DEVICES += actiontec_r1000h
+
define Device/comtrend_vr-3025u
$(Device/bcm63xx-cfe)
DEVICE_VENDOR := Comtrend