aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6368.mk
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2023-06-10 21:05:33 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-11 09:58:17 +0200
commit13579e64417545dca6bc878927d9f48f3dfe4af9 (patch)
tree6cc8d774588e9b4e16703285da51fc65e21dd2b8 /target/linux/bmips/image/bcm6368.mk
parentdf34f71be4aeb849461997f6de70124cfe778604 (diff)
downloadupstream-13579e64417545dca6bc878927d9f48f3dfe4af9.tar.gz
upstream-13579e64417545dca6bc878927d9f48f3dfe4af9.tar.bz2
upstream-13579e64417545dca6bc878927d9f48f3dfe4af9.zip
bmips: add support for Netgear EVG2000
The Netgear EVG2000 is a wifi gigabit router, 2.4 GHz single band with two internal antennas integrated in the main PCB. Hardware: - SoC: Broadcom BCM6369 - CPU: dual core BMIPS4350 V3.1 @400Mhz - RAM: 64 MB DDR - Flash: 16 MB parallel NOR - LAN switch: Broadcom BCM53115, 5x 1Gbit - Wifi 2.4 GHz: Broadcom BCM4322 802.11bgn - USB: 2x 2.0 - Buttons: 2x, 1 reset - LEDs: 10x - FXS: 2x - UART: yes Installation via CFE web UI: 1. Power off the router and make a temporal TX-RX shortcircuit on the serial pins. 2. Power on the router and wait 3 or more seconds 3. Remove the TX-RX shortcircuit 4. Browse to http://192.168.1.1 or http://192.168.0.1 and upload the firmware 5. Wait a few minutes for it to finish Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/bmips/image/bcm6368.mk')
-rw-r--r--target/linux/bmips/image/bcm6368.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index 41bce9e938..82d7608fba 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -43,6 +43,21 @@ define Device/netgear_dgnd3800b
endef
TARGET_DEVICES += netgear_dgnd3800b
+define Device/netgear_evg2000
+ $(Device/bcm63xx_netgear)
+ DEVICE_MODEL := EVG2000
+ CFE_BOARD_ID := 96369PVG
+ CHIP_ID := 6368
+ SOC := bcm6369
+ BLOCKSIZE := 0x20000
+ NETGEAR_BOARD_ID := U12H154T90_NETGEAR
+ NETGEAR_REGION := 1
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-4322-sprom \
+ kmod-leds-gpio
+endef
+TARGET_DEVICES += netgear_evg2000
+
define Device/observa_vh4032n
$(Device/bcm63xx-cfe)
DEVICE_VENDOR := Observa