aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 10:10:28 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 10:21:58 +0200
commitd11a7c4d95a5ecbd2b12750be63349a3d0da2d53 (patch)
tree03b2692ad76170924f92bde33e1513e413b5ea14 /target/linux/bmips/image/Makefile
parentd309160d301a5530a4db3938ee287886555c1b3b (diff)
downloadupstream-d11a7c4d95a5ecbd2b12750be63349a3d0da2d53.tar.gz
upstream-d11a7c4d95a5ecbd2b12750be63349a3d0da2d53.tar.bz2
upstream-d11a7c4d95a5ecbd2b12750be63349a3d0da2d53.zip
bmips: use sercomm-pid script
Make use of sercomm-pid script for generating the Sercomm PID, which avoids having to add an array of hex bytes for every new Sercomm device. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/image/Makefile')
-rw-r--r--target/linux/bmips/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/bmips/image/Makefile b/target/linux/bmips/image/Makefile
index 907779847d..da328f7216 100644
--- a/target/linux/bmips/image/Makefile
+++ b/target/linux/bmips/image/Makefile
@@ -194,12 +194,18 @@ define Build/cfe-sercomm-crypto
endef
define Build/cfe-sercomm-load
+ $(TOPDIR)/scripts/sercomm-pid.py \
+ --hw-version $(SERCOMM_HWVER) \
+ --sw-version $(SERCOMM_SWVER) \
+ --extra-padding-size 0x10 \
+ --pid-file $@.pid
$(TOPDIR)/scripts/sercomm-payload.py \
--input-file $@ \
--output-file $@.new \
- --pid "$(SERCOMM_PID)"
+ --pid-file $@.pid
mv $@.new $@
+ rm -f $@.pid
endef
define Build/cfe-sercomm-part