aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-21 10:00:18 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-22 18:29:44 +0100
commit029093a302c9a66b74bec46285a179abd122a40a (patch)
tree505f9d21adf4f5d9acb51e7618f72cdbbc2d2ef9 /target/linux/bmips/Makefile
parentc27532742d8cae7b9c1a8c2fbfe5157e65a20877 (diff)
downloadupstream-029093a302c9a66b74bec46285a179abd122a40a.tar.gz
upstream-029093a302c9a66b74bec46285a179abd122a40a.tar.bz2
upstream-029093a302c9a66b74bec46285a179abd122a40a.zip
bmips: add new target
This target has full device tree support, thus reducing the number of patches needed for bcm63xx, in which there's a patch for every board. The intention is to start with a minimal amount of downstream patches and start upstreaming all of them. Current status: - Enabling EHCI/OHCI on BCM6358 causes a kernel panic. - BCM63268 lacks Timer Clocks/Reset support. - No PCI/PCIe drivers. - No ethernet drivers. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bmips/Makefile')
-rw-r--r--target/linux/bmips/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/bmips/Makefile b/target/linux/bmips/Makefile
new file mode 100644
index 0000000000..0adc8cd97e
--- /dev/null
+++ b/target/linux/bmips/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+CPU_TYPE:=mips32
+BOARD:=bmips
+BOARDNAME:=Broadcom BMIPS
+SUBTARGETS:=generic nand
+FEATURES:=gpio source-only squashfs usb
+
+KERNEL_PATCHVER:=5.10
+
+define Target/Description
+ Build firmware images for BCM33xx cable modem chips,
+ BCM63xx DSL chips and BCM7xxx set-top box chips.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-gpio-button-hotplug
+
+$(eval $(call BuildTarget))