aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-12-27 20:44:11 -0800
committerPaul Spooren <mail@aparcar.org>2023-02-04 02:35:03 +0100
commit2630e5063df0240eb0d05cd6e953b2bd412e3215 (patch)
treec420021efd2ad444bf7e4f9e83675fdd43ae483e /target/linux/bcm63xx
parent19988b66d07f44be757c4a0e41be899dbf8c72dd (diff)
downloadupstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.gz
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.bz2
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.zip
treewide: replace wpad-basic-wolfssl default
The newly merged mbedtls backend is smaller and has fewer ABI related issues than the wolfSSL one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx')
-rw-r--r--target/linux/bcm63xx/image/Makefile10
-rw-r--r--target/linux/bcm63xx/profiles/default.mk2
2 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index f35358173c..9137971fa5 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -305,12 +305,12 @@ define Device/Default
endef
DEVICE_VARS += CHIP_ID DEVICE_LOADADDR
-ATH5K_PACKAGES := kmod-ath5k wpad-basic-wolfssl
-ATH9K_PACKAGES := kmod-ath9k wpad-basic-wolfssl
-B43_PACKAGES := kmod-b43 wpad-basic-wolfssl
+ATH5K_PACKAGES := kmod-ath5k wpad-basic-mbedtls
+ATH9K_PACKAGES := kmod-ath9k wpad-basic-mbedtls
+B43_PACKAGES := kmod-b43 wpad-basic-mbedtls
BRCMWL_PACKAGES := kmod-brcm-wl nas wlc
-RT28_PACKAGES := kmod-rt2800-pci wpad-basic-wolfssl
-RT61_PACKAGES := kmod-rt61-pci wpad-basic-wolfssl
+RT28_PACKAGES := kmod-rt2800-pci wpad-basic-mbedtls
+RT61_PACKAGES := kmod-rt61-pci wpad-basic-mbedtls
USB1_PACKAGES := kmod-usb-ohci kmod-usb-ledtrig-usbport
USB2_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
diff --git a/target/linux/bcm63xx/profiles/default.mk b/target/linux/bcm63xx/profiles/default.mk
index 3e8b07d35f..65f2111087 100644
--- a/target/linux/bcm63xx/profiles/default.mk
+++ b/target/linux/bcm63xx/profiles/default.mk
@@ -4,7 +4,7 @@
define Profile/Default
NAME:=Default Profile
- PACKAGES:=kmod-b43 wpad-basic-wolfssl
+ PACKAGES:=kmod-b43 wpad-basic-mbedtls
PRIORITY:=1
endef