aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-02 18:00:40 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-02 20:37:56 +0100
commit05603df730a5f9c24f433bf6ecf4dc1088e5fe23 (patch)
tree5939083b9f89ddf97482876546ca8923d4a4d32b /target/linux/bcm63xx
parent766270061305eb0ad18f241f907b321744b692bc (diff)
downloadupstream-05603df730a5f9c24f433bf6ecf4dc1088e5fe23.tar.gz
upstream-05603df730a5f9c24f433bf6ecf4dc1088e5fe23.tar.bz2
upstream-05603df730a5f9c24f433bf6ecf4dc1088e5fe23.zip
bcm63xx: loader-lzma: drop unused RAMSIZE parameter
This parameter has never been used. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx')
-rw-r--r--target/linux/bcm63xx/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index 9137971fa5..45b526878d 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -8,8 +8,7 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80010000 # RAM start + 64K
LOADER_ENTRY = 0x80a00000 # RAM start + 10M, for relocate
-RAMSIZE = 0x02000000 # 32MB
-LZMA_TEXT_START = 0x81800000 # 32MB - 8MB
+LZMA_TEXT_START = 0x81800000 # RAM start + 24M
RELOCATE_MAKEOPTS= \
CACHELINE_SIZE=16 \
@@ -37,7 +36,6 @@ define Build/loader-lzma
KDIR=$(KDIR) \
LOADER_ADDR=$(if $(DEVICE_LOADADDR),$(DEVICE_LOADADDR),$(LOADER_ENTRY)) \
KERNEL_ADDR=$(KERNEL_LOADADDR) \
- RAMSIZE=$(RAMSIZE) \
LZMA_TEXT_START=$(LZMA_TEXT_START) \
CHIP_ID=$(CHIP_ID) \
PKG_BUILD_DIR="$@.src" \