aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-02 17:56:31 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-02 18:23:40 +0200
commit824cb78cf33524b335bd51c7241231bf13b48cd1 (patch)
tree1954891f99448f3c75f03d8a88d2e95257176be6 /target/linux/bcm63xx
parent18d2eeab8e4b12fd8c1083a760cf00e519a913f9 (diff)
downloadupstream-824cb78cf33524b335bd51c7241231bf13b48cd1.tar.gz
upstream-824cb78cf33524b335bd51c7241231bf13b48cd1.tar.bz2
upstream-824cb78cf33524b335bd51c7241231bf13b48cd1.zip
bcm63xx: nand: add CFE_WFI_VERSION values for each device
CFE_WFI_VERSION should be defined per device instead of using a generic value. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx')
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index 7dff893e4f..a42c469197 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -28,7 +28,7 @@ define Device/bcm63xx-nand
CFE_RAM_FILE :=
CFE_RAM_JFFS2_NAME :=
CFE_RAM_JFFS2_PAD :=
- CFE_WFI_VERSION := 0x5731
+ CFE_WFI_VERSION :=
CFE_WFI_CHIP_ID = 0x$$(CHIP_ID)
CFE_WFI_FLASH_TYPE :=
CFE_WFI_FLAGS :=
@@ -59,6 +59,7 @@ define Device/comtrend_vr-3032u
SUBPAGESIZE := 512
VID_HDR_OFFSET := 2048
DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_VERSION := 0x5731
CFE_WFI_FLASH_TYPE := 3
endef
TARGET_DEVICES += comtrend_vr-3032u
@@ -76,6 +77,7 @@ define Device/comtrend_vg-8050
SUBPAGESIZE := 512
VID_HDR_OFFSET := 2048
DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_VERSION := 0x5731
CFE_WFI_FLASH_TYPE := 3
endef
TARGET_DEVICES += comtrend_vg-8050
@@ -115,6 +117,7 @@ define Device/netgear_dgnd3700-v2
BLOCKSIZE := 16k
PAGESIZE := 512
DEVICE_PACKAGES += $(B43_PACKAGES) $(USB2_PACKAGES)
+ CFE_WFI_VERSION := 0x5731
CFE_WFI_FLASH_TYPE := 2
endef
TARGET_DEVICES += netgear_dgnd3700-v2
@@ -134,6 +137,7 @@ define Device/sercomm_ad1018
VID_HDR_OFFSET := 2048
DEVICE_PACKAGES += $(B43_PACKAGES) $(USB2_PACKAGES)
CFE_WFI_FLASH_TYPE := 3
+ CFE_WFI_VERSION := 0x5731
SERCOMM_PID := \
30 30 30 30 30 30 30 31 34 31 35 31 35 33 30 30 \
30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \