aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-19 10:21:46 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-19 10:41:47 +0200
commitdaee6b466146fc20505adb2ef9f4be831f96d972 (patch)
treefedd82f8ad405908856957ed81983dd9eba2e210 /target/linux/bcm63xx/image
parent62e7342ddfba605722b1d6700eec3f0aaa9377e5 (diff)
downloadupstream-daee6b466146fc20505adb2ef9f4be831f96d972.tar.gz
upstream-daee6b466146fc20505adb2ef9f4be831f96d972.tar.bz2
upstream-daee6b466146fc20505adb2ef9f4be831f96d972.zip
bcm63xx: add Comtrend VG-8050 support
BCM63169 with 128M RAM, 128M NAND and BCM53125 switch. Switch is connected by HSSPI to CS5. More info: https://openwrt.org/toh/comtrend/vg8050 Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx/image')
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index c0505aceaa..9ff2c989b8 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -52,6 +52,23 @@ define Device/comtrend_vr-3032u
endef
TARGET_DEVICES += comtrend_vr-3032u
+define Device/comtrend_vg-8050
+ $(Device/bcm63xx-nand)
+ DEVICE_VENDOR := Comtrend
+ DEVICE_MODEL := VG-8050
+ CFE_CHIP_ID := 63268
+ SOC := bcm63169
+ CFE_RAM_FILE := comtrend,vg-8050/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_FLASH_TYPE := 3
+endef
+TARGET_DEVICES += comtrend_vg-8050
+
### Netgear ###
define Device/netgear_dgnd3700-v2
$(Device/bcm63xx-nand)