aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/bcm63xx_nand.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-20 09:21:34 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-20 09:21:34 +0200
commit91b275b6e3592e20f311a4434c43ee302347cf57 (patch)
tree8a6f726ca9021baf49aaf79fe3e04258fd0b04aa /target/linux/bcm63xx/image/bcm63xx_nand.mk
parente0382c50e992753b8616efdf95285419286765de (diff)
downloadupstream-91b275b6e3592e20f311a4434c43ee302347cf57.tar.gz
upstream-91b275b6e3592e20f311a4434c43ee302347cf57.tar.bz2
upstream-91b275b6e3592e20f311a4434c43ee302347cf57.zip
bcm63xx: image: rename CFE_CHIP_ID to CHIP_ID
Rename CFE_CHIP_ID to a generic name that doesn't involve CFE. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx/image/bcm63xx_nand.mk')
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index 012745bbac..aeaf6f2ae5 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -21,12 +21,11 @@ define Device/bcm63xx-nand
IMAGE/cfe.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | cfe-jffs2-cferam | append-ubi | cfe-wfi-tag
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
KERNEL_SIZE := 5120k
- CFE_CHIP_ID :=
CFE_RAM_FILE :=
CFE_RAM_JFFS2_NAME :=
CFE_RAM_JFFS2_PAD :=
CFE_WFI_VERSION := 0x5731
- CFE_WFI_CHIP_ID = 0x$$(CFE_CHIP_ID)
+ CFE_WFI_CHIP_ID = 0x$$(CHIP_ID)
CFE_WFI_FLASH_TYPE :=
CFE_WFI_FLAGS :=
UBINIZE_OPTS := -E 5
@@ -39,7 +38,7 @@ define Device/comtrend_vr-3032u
$(Device/bcm63xx-nand)
DEVICE_VENDOR := Comtrend
DEVICE_MODEL := VR-3032u
- CFE_CHIP_ID := 63268
+ CHIP_ID := 63268
SOC := bcm63168
CFE_RAM_FILE := comtrend,vr-3032u/cferam.000
CFE_RAM_JFFS2_NAME := cferam.000
@@ -56,7 +55,7 @@ define Device/comtrend_vg-8050
$(Device/bcm63xx-nand)
DEVICE_VENDOR := Comtrend
DEVICE_MODEL := VG-8050
- CFE_CHIP_ID := 63268
+ CHIP_ID := 63268
SOC := bcm63169
CFE_RAM_FILE := comtrend,vg-8050/cferam.000
CFE_RAM_JFFS2_NAME := cferam.000
@@ -75,7 +74,7 @@ define Device/netgear_dgnd3700-v2
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := DGND3700
DEVICE_VARIANT := v2
- CFE_CHIP_ID := 6362
+ CHIP_ID := 6362
CFE_RAM_FILE := netgear,dgnd3700-v2/cferam
CFE_RAM_JFFS2_NAME := cferam
CFE_RAM_JFFS2_PAD := 496k
@@ -92,7 +91,7 @@ define Device/sercomm_ad1018
IMAGE/cfe.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | ad1018-jffs2-cferam | append-ubi | cfe-wfi-tag
DEVICE_VENDOR := Sercomm
DEVICE_MODEL := AD1018
- CFE_CHIP_ID := 6328
+ CHIP_ID := 6328
CFE_RAM_FILE := sercomm,ad1018/cferam
CFE_RAM_JFFS2_NAME := cferam
BLOCKSIZE := 128k