aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/bcm63xx_nand.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-03 11:20:58 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-03 11:34:28 +0200
commit231f728f69e0451c44998187cc36ebb0ab9e9ea7 (patch)
tree6a2a7bdecbebedd9f4d8cdac4da1cc2d08947857 /target/linux/bcm63xx/image/bcm63xx_nand.mk
parent39f44be1dc85b0cf16ede5ae037cb0487fad0a9b (diff)
downloadupstream-231f728f69e0451c44998187cc36ebb0ab9e9ea7.tar.gz
upstream-231f728f69e0451c44998187cc36ebb0ab9e9ea7.tar.bz2
upstream-231f728f69e0451c44998187cc36ebb0ab9e9ea7.zip
bcm63xx: ad1018: remove cfe.bin image support
Apparently, Sercomm allows loading a BCM WFI image via CFE, but this image destroys "serial" and "protect" nand partitions, which is wrong. It will also set both bootflags to the same value, which causes booting issues with cferam (cferom will alternatively boot from cferam1 or cferam2 each time the device is rebooted). Now that OEM Sercomm images are supported it's time to remove this hacky cfe.bin image support. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx/image/bcm63xx_nand.mk')
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index 74f23f52af..7b2039c988 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -39,7 +39,7 @@ endef
define Device/sercomm-nand
$(Device/bcm63xx-nand)
- IMAGES += factory.img
+ IMAGES = factory.img sysupgrade.bin
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | cfe-sercomm-part | gzip | cfe-sercomm-load | cfe-sercomm-crypto
SERCOM_PID :=
SERCOMM_VERSION :=
@@ -125,7 +125,6 @@ TARGET_DEVICES += netgear_dgnd3700-v2
### Sercomm ###
define Device/sercomm_ad1018
$(Device/sercomm-nand)
- IMAGE/cfe.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | ad1018-jffs2-cferam | append-ubi | cfe-wfi-tag
DEVICE_VENDOR := Sercomm
DEVICE_MODEL := AD1018
CHIP_ID := 6328