aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-20 09:14:02 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-20 11:15:29 +0200
commitc93cdf536a086deab0fa696989263a97b4d6c417 (patch)
tree962a57d8e1150af8504eaf3b57e5d51a768f64d2 /target/linux/bcm63xx/image/Makefile
parent8e8920c92f1346ff1898b8674bc79d9a1a3ea59e (diff)
downloadupstream-c93cdf536a086deab0fa696989263a97b4d6c417.tar.gz
upstream-c93cdf536a086deab0fa696989263a97b4d6c417.tar.bz2
upstream-c93cdf536a086deab0fa696989263a97b4d6c417.zip
bcm63xx: lzma-loader: rely on CHIP_ID for UART address
lzma-loader uart output wasn't working on BCM3380/BCM6362 because these SoCs have the same processor ID. Let's use CHIP_ID for establishing the UART base address. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx/image/Makefile')
-rw-r--r--target/linux/bcm63xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index ff9ec01c45..7c3091fb66 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -17,7 +17,8 @@ LOADER_MAKEOPTS= \
KDIR=$(KDIR) \
LOADADDR=$(KERNEL_LOADADDR) \
RAMSIZE=$(RAMSIZE) \
- LZMA_TEXT_START=$(LZMA_TEXT_START)
+ LZMA_TEXT_START=$(LZMA_TEXT_START) \
+ CHIP_ID=$(CHIP_ID)
RELOCATE_MAKEOPTS= \
CACHELINE_SIZE=16 \