aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-03 17:19:03 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-05-12 12:34:57 +0200
commita0081b19452d8f052757bbe356a6e037ff9afdd3 (patch)
treeaa71257bb0e860953a2615fd78d640e29b7fcf16 /target/linux/bcm63xx/image/Makefile
parent84646936a6480002b9a04e01ff05530126512bcf (diff)
downloadupstream-a0081b19452d8f052757bbe356a6e037ff9afdd3.tar.gz
upstream-a0081b19452d8f052757bbe356a6e037ff9afdd3.tar.bz2
upstream-a0081b19452d8f052757bbe356a6e037ff9afdd3.zip
bcm63xx: loader-lzma: use default lzma
Specific CFE LZMA parameters aren't needed for LZMA Loader. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx/image/Makefile')
-rw-r--r--target/linux/bcm63xx/image/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index f6d2bf4bbd..9ef7a91ce7 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -53,20 +53,16 @@ define Build/loader-lzma
rm -rf $@.src
endef
-define Build/lzma
+define Build/lzma-cfe
# CFE is a LZMA nazi! It took me hours to find out the parameters!
# Also I think lzma has a bug cause it generates different output depending on
# if you use stdin / stdout or not. Use files instead of stdio here, cause
# otherwise CFE will complain and not boot the image.
- $(STAGING_DIR_HOST)/bin/lzma e $@ -d22 -fb64 -a1 $@.lzma
- mv $@.lzma $@
-endef
-
-define Build/lzma-cfe
+ $(call Build/lzma-no-dict,-d22 -fb64 -a1)
# Strip out the length, CFE doesn't like this
- dd if=$@ of=$@.lzma.cfe bs=5 count=1
- dd if=$@ of=$@.lzma.cfe ibs=13 obs=5 skip=1 seek=1 conv=notrunc
- mv $@.lzma.cfe $@
+ dd if=$@ of=$@.new bs=5 count=1
+ dd if=$@ of=$@.new ibs=13 obs=5 skip=1 seek=1 conv=notrunc
+ mv $@.new $@
endef
define Build/relocate-kernel