aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2022-12-16 21:52:27 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-26 22:22:48 +0100
commit4d903a50099b5c35063b92b39d196e34e1a14ec6 (patch)
treeac125c29b624a78cbc37f3c017ebd6f6708436a5 /target/linux/bcm53xx
parent1e138ca70381c71915b7fb918d4294dcb7ba0cb2 (diff)
downloadupstream-4d903a50099b5c35063b92b39d196e34e1a14ec6.tar.gz
upstream-4d903a50099b5c35063b92b39d196e34e1a14ec6.tar.bz2
upstream-4d903a50099b5c35063b92b39d196e34e1a14ec6.zip
bcm53xx: Add support for D-Link DWL-8610AP
The D-Link DWL-8610AP is a pretty straight-forward BC53016 device, D-Link has invented a firmware package format which is a tar file, and we implement this for the factory image. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index ed2e9c6821..1cb08effce 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -105,6 +105,22 @@ define Build/seama-nand
-i $@.entity
endef
+define Build/dwl8610ap-image
+ mkdir -p $@.tmptar
+ # The DWL8610AP pretends to be a Broadcom reference design
+ echo "bcm953012er" > $@.tmptar/board
+ echo "LVL7" > $@.tmptar/model
+ # Something high beyond what D-Link has put out
+ echo "5.0.0.0" > $@.tmptar/version
+ # Create rootfs.bin, this is just a NAND image including everything
+ cp $@ $@.tmptar/rootfs.bin
+ # Hash the rootfs.bin
+ cat $@.tmptar/rootfs.bin | md5sum > $@.tmptar/rootfs.md5
+ cd $@.tmptar && tar -c -f $@.new *
+ rm -rf $@.tmptar
+ mv $@.new $@
+endef
+
DEVICE_VARS += ASUS_PRODUCTID
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
DEVICE_VARS += SIGNATURE
@@ -250,6 +266,15 @@ define Device/dlink_dir-885l
endef
TARGET_DEVICES += dlink_dir-885l
+define Device/dlink_dwl-8610ap
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DWL-8610AP
+ DEVICE_PACKAGES := $(B43)
+ IMAGES := factory.tar
+ IMAGE/factory.tar := append-ubi | trx-nand | dwl8610ap-image
+endef
+TARGET_DEVICES += dlink_dwl-8610ap
+
define Device/linksys_ea6300-v1
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA6300