aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorArınç ÜNAL <arinc.unal@arinc9.com>2022-10-18 11:54:20 +0300
committerRafał Miłecki <rafal@milecki.pl>2022-10-21 08:50:51 +0200
commit2b9bb5b187022f8b64c84781c071d6c2b0ce3e45 (patch)
treeb4d9507549b8f83ccd7cef2253344b52dc45f63a /target/linux/bcm53xx
parentc15e7e291072b90cc23884d25f0462bc358e8e4a (diff)
downloadupstream-2b9bb5b187022f8b64c84781c071d6c2b0ce3e45.tar.gz
upstream-2b9bb5b187022f8b64c84781c071d6c2b0ce3e45.tar.bz2
upstream-2b9bb5b187022f8b64c84781c071d6c2b0ce3e45.zip
bcm53xx: enable Broadcom 4366b1 firmware for Asus RT-AC88U
On some of the hardware revisions of Asus RT-AC88U, brcmfmac detects the 4366b1 wireless chip and tries to load the firmware file which doesn't exist because it's not included in the image. Therefore, include firmware for 4366b1 along with 4366c0. This way, all hardware revisions of the router will be supported by having brcmfmac use the firmware file for the wireless chip it detects. Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index d101ff95a7..ed0b755364 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -170,7 +170,7 @@ TARGET_DEVICES += asus_rt-ac87u
define Device/asus_rt-ac88u
$(call Device/asus)
DEVICE_MODEL := RT-AC88U
- DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
ASUS_PRODUCTID := RT-AC88U
endef
TARGET_DEVICES += asus_rt-ac88u