aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorArınç ÜNAL <arinc.unal@arinc9.com>2021-11-12 18:56:15 +0800
committerRafał Miłecki <rafal@milecki.pl>2022-06-07 16:18:20 +0200
commitbee8612d4f3ef4323bc15a4fe8ddfddadf5ab367 (patch)
treefa9bce62f7a3e7e53e1116feeaee7a710648796d /target/linux/bcm53xx
parentee4a7650901c522cc51775589c9ef6da1ade244b (diff)
downloadupstream-bee8612d4f3ef4323bc15a4fe8ddfddadf5ab367.tar.gz
upstream-bee8612d4f3ef4323bc15a4fe8ddfddadf5ab367.tar.bz2
upstream-bee8612d4f3ef4323bc15a4fe8ddfddadf5ab367.zip
bcm53xx: add support for Asus RT-AC88U
Asus RT-AC88U is an AC3100 router featuring 9 Ethernet ports over the integrated Broadcom and the external Realtek switch. Hardware info: * Processor: Broadcom BCM4709C0KFEBG dual-core @ 1.4 GHz * Switch: BCM53012 in BCM4709C0KFEBG & external RTL8365MB * DDR3 RAM: 512 MB * Flash: 128 MB (ESMT F59L1G81LA-25T) * 2.4GHz: BCM4366 4×4 2.4/5G single chip 802.11ac SoC * 5GHz: BCM4366 4×4 2.4/5G single chip 802.11ac SoC * Ports: 8 Ports, 1 WAN Ports Flashing instructions: * Boot to CFE Recovery Mode by holding the reset button while power-on. * Connect to the router with an ethernet cable. * Set IPv4 address of the computer to 192.168.1.2 subnet 255.255.255.0. * Head to http://192.168.1.1. * Reset NVRAM. * Upload the OpenWrt image. CFE bootloader may reject flashing the image due to image integrity check. In that case, follow the instructions below. * Rename the OpenWrt image as firmware.trx. * Run a TFTP server and make it serve the firmware.trx file. * Run the URL below on a browser or curl. http://192.168.1.1/do.htm?cmd=flash+-noheader+192.168.1.2:firmware.trx+flash0.trx Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com> [rmilecki: mark BROKEN until we sort out nvram & CFE recovery] Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 72b9b721d707b7f70109eb70b2a9f22449ceba08)
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/bcm53xx/image/Makefile9
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/base-files/etc/board.d/02_network b/target/linux/bcm53xx/base-files/etc/board.d/02_network
index 6d970e1d0e..822320c0a6 100644
--- a/target/linux/bcm53xx/base-files/etc/board.d/02_network
+++ b/target/linux/bcm53xx/base-files/etc/board.d/02_network
@@ -13,6 +13,9 @@ bcm53xx_setup_interfaces()
asus,rt-ac87u)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
;;
+ asus,rt-ac88u)
+ ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 extsw" "wan"
+ ;;
linksys,panamera)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 extsw" "wan"
;;
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index aadac9c3d4..3df24013ce 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -167,6 +167,15 @@ define Device/asus_rt-ac87u
endef
TARGET_DEVICES += asus_rt-ac87u
+define Device/asus_rt-ac88u
+ $(call Device/asus)
+ DEVICE_MODEL := RT-AC88U
+ DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC88U
+ BROKEN := y
+endef
+TARGET_DEVICES += asus_rt-ac88u
+
define Device/asus_rt-n18u
$(call Device/asus)
DEVICE_MODEL := RT-N18U