aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorDamien Mascord <tusker@tusker.org>2021-07-19 14:21:44 +1000
committerChristian Lamparter <chunkeey@gmail.com>2021-09-23 20:49:32 +0200
commitfd67908647390b916470501c88b4f5258123da95 (patch)
tree98f1a3a76f3823541543acc913be1b804d03cf36 /target/linux/bcm53xx
parent96e05e2e36fc3d0a893702a7c445aac0348320a4 (diff)
downloadupstream-fd67908647390b916470501c88b4f5258123da95.tar.gz
upstream-fd67908647390b916470501c88b4f5258123da95.tar.bz2
upstream-fd67908647390b916470501c88b4f5258123da95.zip
scripts: mkits.sh: Allow legacy @ mode for dts creation
commit 5ec60cbe9d94 ("scripts: mkits.sh: replace @ with - in nodes") broke support for Meraki MR32 and this patch makes the replacement configurable allowing for specifying the @ or - or whatever character that is desired to retain backwards compatibility with existing devices. For example, this patch includes the fix for the Meraki MR32 in target/linux/bcm53xx/image for meraki_mr32: DEVICE_DTS_DELIMITER := @ DEVICE_DTS_CONFIG := config@1 Fixes: 5ec60cbe9d94 ("scripts: mkits.sh: replace @ with - in nodes") Signed-off-by: Damien Mascord <tusker@tusker.org> [Added tags, checkpatch.pl fixes, noted that this is for old stuff] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index b2a7da80c5..45355e1ec9 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -328,10 +328,12 @@ define Device/meraki_mr32
# if the partition is smaller than the old one.
KERNEL_LOADADDR := 0x00008000
KERNEL_INITRAMFS_SUFFIX := .bin
+ DEVICE_DTS_DELIMITER := @
+ DEVICE_DTS_CONFIG := config@1
KERNEL_INITRAMFS := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb | \
pad-to 10362880
KERNEL := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
- IMAGES := sysupgrade.bin
+ IMAGES += sysupgrade.bin
# Currently the only device that uses the new image check
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -437,7 +439,7 @@ define Device/tplink_archer-c5-v2
TPLINK_BOARD := ARCHER-C5-V2
BROKEN := y
endef
-TARGET_DEVICES += tplink_archer-c5-v2
+#TARGET_DEVICES += tplink_archer-c5-v2
define Device/tplink_archer-c9-v1
DEVICE_VENDOR := TP-Link
@@ -449,6 +451,6 @@ define Device/tplink_archer-c9-v1
TPLINK_BOARD := ARCHERC9
BROKEN := y
endef
-TARGET_DEVICES += tplink_archer-c9-v1
+#TARGET_DEVICES += tplink_archer-c9-v1
$(eval $(call BuildImage))