aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-04-04 14:53:25 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-04-04 14:53:25 +0000
commit157cb923cbab2a1ee8d84b0710fbc3d08e7bfdfb (patch)
tree6df7f719ffe6f24c6e6db2bec03668fb5990053b /target/linux/bcm53xx
parent27fbf299922a586a674cc3780d7824556b9fa053 (diff)
downloadupstream-157cb923cbab2a1ee8d84b0710fbc3d08e7bfdfb.tar.gz
upstream-157cb923cbab2a1ee8d84b0710fbc3d08e7bfdfb.tar.bz2
upstream-157cb923cbab2a1ee8d84b0710fbc3d08e7bfdfb.zip
bcm53xx: prepare for building D-Link DIR-885L image
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Partial backport of r48606 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49117 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile33
1 files changed, 32 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 32124c71e1..7cc76607d5 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -66,7 +66,24 @@ define Build/netgear-chk
mv $@.new $@
endef
-DEVICE_VARS += DT PRODUCTID BOARD_ID REGION
+define Build/seama-nand
+ # Seama entity
+ $(STAGING_DIR_HOST)/bin/oseama \
+ entity $@.entity \
+ -m "dev=/dev/mtdblock/7" \
+ -m "type=firmware" \
+ -f $(word 1,$^) \
+ -b 0x400000 \
+ -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
+ -f $(KDIR)/ubi_mark
+ # Seama container
+ $(STAGING_DIR_HOST)/bin/seama \
+ -s $@ \
+ -m "signature=$(SIGNATURE)" \
+ -i $@.entity
+endef
+
+DEVICE_VARS += DT PRODUCTID SIGNATURE BOARD_ID REGION
define Device/Default
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
@@ -93,6 +110,19 @@ define AsusDevice
TARGET_DEVICES += asus-$(1)
endef
+define Device/dlink
+ IMAGES := bin
+ IMAGE/bin := seama-nand
+endef
+
+define DLinkDevice
+ define Device/dlink-$(1)
+ $$(Device/dlink)
+ SIGNATURE := $(2)
+ endef
+ TARGET_DEVICES += dlink-$(1)
+endef
+
define Device/netgear
IMAGES := chk
IMAGE/chk := trx-nand | netgear-chk
@@ -137,6 +167,7 @@ $(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
$(eval $(call AsusDevice,rt-n18u,RT-N18U))
+# $(eval $(call DLinkDevice,dir-885l,wrgac42_dlink.2015_dir885l))
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
# $(eval $(call NetgearDevice,r8500,U12H334T00_NETGEAR))