aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2020-08-04 10:31:11 +0200
committerRafał Miłecki <rafal@milecki.pl>2020-08-04 13:27:19 +0200
commitc8c98766071944b4725ef2a0467a14dcdea4fc1a (patch)
tree1af9352eb013e603c855f3b7522af1ba03a6b541 /target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
parentb9cd55b88eb3f6a1d079b043415fb7e742d073f9 (diff)
downloadupstream-c8c98766071944b4725ef2a0467a14dcdea4fc1a.tar.gz
upstream-c8c98766071944b4725ef2a0467a14dcdea4fc1a.tar.bz2
upstream-c8c98766071944b4725ef2a0467a14dcdea4fc1a.zip
bcm53xx: update kernel 5.4 DTS to upstream 5.9 state
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch')
-rw-r--r--target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch82
1 files changed, 82 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch b/target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
new file mode 100644
index 0000000000..67e85da61f
--- /dev/null
+++ b/target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
@@ -0,0 +1,82 @@
+From 984829e2d39b5ba9f817198d701c85511ef40528 Mon Sep 17 00:00:00 2001
+From: Dan Haab <dan.haab@legrand.com>
+Date: Wed, 2 Oct 2019 09:57:26 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XWC-2000
+
+It's a simple network device based on BCM47094 with just a single
+Ethernet port.
+
+Signed-off-by: Dan Haab <dan.haab@legrand.com>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile | 1 +
+ arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 53 +++++++++++++++++++
+ 2 files changed, 54 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -113,6 +113,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+ bcm47094-luxul-abr-4500.dtb \
+ bcm47094-luxul-xap-1610.dtb \
+ bcm47094-luxul-xbr-4500.dtb \
++ bcm47094-luxul-xwc-2000.dtb \
+ bcm47094-luxul-xwr-3100.dtb \
+ bcm47094-luxul-xwr-3150-v1.dtb \
+ bcm47094-netgear-r8500.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+@@ -0,0 +1,53 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright 2019 Legrand AV Inc.
++ */
++
++/dts-v1/;
++
++#include "bcm47094.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++ compatible = "luxul,xwc-2000-v1", "brcm,bcm47094", "brcm,bcm4708";
++ model = "Luxul XWC-2000 V1";
++
++ chosen {
++ bootargs = "earlycon";
++ };
++
++ memory {
++ reg = <0x00000000 0x08000000
++ 0x88000000 0x18000000>;
++ };
++
++ leds {
++ compatible = "gpio-leds";
++
++ status {
++ label = "bcm53xx:green:status";
++ gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "timer";
++ };
++ };
++
++ gpio-keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ restart {
++ label = "Reset";
++ linux,code = <KEY_RESTART>;
++ gpios = <&chipcommon 19 GPIO_ACTIVE_LOW>;
++ };
++ };
++};
++
++&uart1 {
++ status = "okay";
++};
++
++&spi_nor {
++ status = "okay";
++};