aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2018-05-12 15:39:12 +0200
committerRafał Miłecki <rafal@milecki.pl>2018-05-12 15:39:50 +0200
commit3c81d12ec32844a731f37b011b30a3586731f98e (patch)
tree2defc3e542f4f3cc2bc8c269e9e500e87a483d17 /target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch
parentb07875308476fda1270bd780f95122421fde26d4 (diff)
downloadupstream-3c81d12ec32844a731f37b011b30a3586731f98e.tar.gz
upstream-3c81d12ec32844a731f37b011b30a3586731f98e.tar.bz2
upstream-3c81d12ec32844a731f37b011b30a3586731f98e.zip
bcm53xx: backport the first bunch of 4.18 BCM5301X patches
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch')
-rw-r--r--target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch112
1 files changed, 112 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch b/target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch
new file mode 100644
index 0000000000..6cd7b67897
--- /dev/null
+++ b/target/linux/bcm53xx/patches-4.4/051-v4.18-0004-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWR-3150-V1.patch
@@ -0,0 +1,112 @@
+From 2e2105a1578172eaf61e3b59a2c10c4fe04c21b9 Mon Sep 17 00:00:00 2001
+From: Dan Haab <riproute@gmail.com>
+Date: Fri, 4 May 2018 10:08:43 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XWR-3150 V1
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Luxul XWR-3150 is a wireless router similar to the XWR-3100 except:
+1) It has more RAM
+2) Its NAND controller in running in BCH8 mode
+3) LAN ports LEDs are hardware controlled
+
+Signed-off-by: Dan Haab <dan.haab@luxul.com>
+Acked-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile | 1 +
+ arch/arm/boot/dts/bcm47094-luxul-xwr-3150-v1.dts | 77 ++++++++++++++++++++++++
+ 2 files changed, 78 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwr-3150-v1.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -88,6 +88,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+ bcm47094-luxul-abr-4500.dtb \
+ bcm47094-luxul-xbr-4500.dtb \
+ bcm47094-luxul-xwr-3100.dtb \
++ bcm47094-luxul-xwr-3150-v1.dtb \
+ bcm47094-netgear-r8500.dtb \
+ bcm94708.dtb \
+ bcm94709.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwr-3150-v1.dts
+@@ -0,0 +1,77 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright 2018 Luxul Inc.
++ */
++
++/dts-v1/;
++
++#include "bcm47094.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++ compatible = "luxul,xwr-3150-v1", "brcm,bcm47094", "brcm,bcm4708";
++ model = "Luxul XWR-3150 V1";
++
++ chosen {
++ bootargs = "earlycon";
++ };
++
++ memory {
++ reg = <0x00000000 0x08000000
++ 0x88000000 0x18000000>;
++ };
++
++ leds {
++ compatible = "gpio-leds";
++
++ power {
++ label = "bcm53xx:green:power";
++ gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "default-on";
++ };
++
++ usb3 {
++ label = "bcm53xx:green:usb3";
++ gpios = <&chipcommon 8 GPIO_ACTIVE_LOW>;
++ trigger-sources = <&ohci_port1>, <&ehci_port1>,
++ <&xhci_port1>;
++ linux,default-trigger = "usbport";
++ };
++
++ status {
++ label = "bcm53xx:green:status";
++ gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "timer";
++ };
++
++ 2ghz {
++ label = "bcm53xx:green:2ghz";
++ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++ };
++
++ 5ghz {
++ label = "bcm53xx:green:5ghz";
++ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ restart {
++ label = "Reset";
++ linux,code = <KEY_RESTART>;
++ gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
++ };
++ };
++};
++
++&usb3 {
++ vcc-gpio = <&chipcommon 18 GPIO_ACTIVE_HIGH>;
++};
++
++&spi_nor {
++ status = "okay";
++};