aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorHao Dong <halbertdong@gmail.com>2019-01-19 17:39:19 +0000
committerRafał Miłecki <rafal@milecki.pl>2019-01-20 23:34:44 +0100
commit62dadcb86c6e6f80ce6fbcd89befc3cc22c2176a (patch)
tree0b2da585ff73c5e3340093c53537f69520f407a3 /target/linux/bcm53xx/image
parent3ccc0fdd9cdb015dbc711366590ec87c95117b0c (diff)
downloadupstream-62dadcb86c6e6f80ce6fbcd89befc3cc22c2176a.tar.gz
upstream-62dadcb86c6e6f80ce6fbcd89befc3cc22c2176a.tar.bz2
upstream-62dadcb86c6e6f80ce6fbcd89befc3cc22c2176a.zip
bcm53xx: add support for Phicomm K3
Hardware specifications: - CPU: Broadcom BCM4709C0 @1.4GHz (Dual-Core ARM) - RAM: 512 MB (DDR3) - Flash: 128 MB (NAND) - LAN ports: 3, LAN speed: 10/100/1000 - WAN ports: 1, WAN speed: 10/100/1000 - 2.4G: BCM4366 4x4 MIMO 1000Mbps -- Skyworks SE2623L 2.4GHz Power Amplifier (x4) - 5G: BCM4366 4x4 MIMO 2167Mbps -- RFMD RFPA5542 5GHz Power Amplifier Module (x4) - USB: 1x USB 3.0 port - 1x LED, 1x reset button, 1x power switch - 1x system status touch screen Flash: - Enter CFE - Upload the trx file - Reboot Signed-off-by: Hao Dong <halbertdong@gmail.com>
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 55db479701..fc18a96232 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -313,6 +313,13 @@ define Device/smartrg-sr400ac
endef
TARGET_DEVICES += smartrg-sr400ac
+define Device/phicomm-k3
+ DEVICE_TITLE := PHICOMM K3
+ DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ IMAGES := trx
+endef
+TARGET_DEVICES += phicomm-k3
+
define Device/tenda-ac9
DEVICE_TITLE := Tenda AC9
DEVICE_PACKAGES := $(B43) $(USB2_PACKAGES)