aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorFUKAUMI Naoki <naobsd@gmail.com>2017-01-29 01:05:55 +0900
committerRafał Miłecki <rafal@milecki.pl>2017-01-31 11:10:53 +0100
commit3b5d29b96e4df80dbfbcc5bbb8a5898a9390c683 (patch)
tree5b8f654a4dc9c9517c8fec20119bff8286d45d40 /target/linux/bcm53xx/image
parent7faee1bc9f9ede0e23de19d6156dc8d769431bb3 (diff)
downloadupstream-3b5d29b96e4df80dbfbcc5bbb8a5898a9390c683.tar.gz
upstream-3b5d29b96e4df80dbfbcc5bbb8a5898a9390c683.tar.bz2
upstream-3b5d29b96e4df80dbfbcc5bbb8a5898a9390c683.zip
bcm53xx: build factory images for WZR-900DHP series
only factory images for DHP-EU and DHP2-JP (fw ver. 2.x) are built. this will not work for DHP-JP/AP/TW (fw ver. 1.x) because they use different buffalo_csum() formula. Signed-off-by: FUKAUMI Naoki <naobsd@gmail.com> Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index e7a628b7d8..1c987dff52 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -38,6 +38,17 @@ define Build/bcm53xx-tplink-safeloader
rm $@.trx
endef
+define Build/buffalo-wzr-header
+ $(eval product=$(word 1,$(1)))
+ $(eval region=$(word 2,$(1)))
+ ( \
+ echo $(product)_$(BUFFALO_TAG_VERSION)_$(BUFFALO_TAG_MINOR)_$(region)_$(BUFFALO_TAG_PLATFORM); \
+ echo filelen=$$(stat -c%s $@); \
+ cat $@ \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define Build/trx-serial
$(STAGING_DIR_HOST)/bin/trx \
-o $@.new \
@@ -85,6 +96,7 @@ define Build/seama-nand
endef
DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
+DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
BRCMFMAC_43602A1 := kmod-brcmfmac brcmfmac-firmware-43602a1-pcie
BRCMFMAC_4366B1 := kmod-brcmfmac brcmfmac-firmware-4366b1-pcie
@@ -151,6 +163,20 @@ TARGET_DEVICES += buffalo-wzr-600dhp2
define Device/buffalo-wzr-900dhp
DEVICE_TITLE := Buffalo WZR-900DHP
DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+ BUFFALO_TAG_PLATFORM := bcm
+ BUFFALO_TAG_VERSION := 9.99
+ BUFFALO_TAG_MINOR := 9.99
+ IMAGES += factory-DHP-EU.bin factory-DHP2-JP.bin
+ IMAGE/factory-DHP-EU.bin := \
+ append-ubi | trx-nand | buffalo-wzr-header WZR-900DHP EU | \
+ buffalo-enc WZR-900DHP $$(BUFFALO_TAG_VERSION) | \
+ buffalo-tag-dhp WZR-900DHP EU mlang20 | buffalo-enc-tag | \
+ buffalo-dhp-image
+ IMAGE/factory-DHP2-JP.bin := \
+ append-ubi | trx-nand | buffalo-wzr-header WZR-900DHP2 JP | \
+ buffalo-enc WZR-900DHP2 $$(BUFFALO_TAG_VERSION) | \
+ buffalo-tag-dhp WZR-900DHP2 JP jp | buffalo-enc-tag | \
+ buffalo-dhp-image
endef
TARGET_DEVICES += buffalo-wzr-900dhp