aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2017-11-17 11:43:33 +0100
committerRafał Miłecki <rafal@milecki.pl>2017-11-17 11:43:33 +0100
commit370ce1fb48ea8b5b8fc2f91ed536a4f306fa9c82 (patch)
tree95a86ce4b295cfea223e24ac1414bc1d65df0c52 /target/linux/bcm53xx/image
parentfb66dc9b03b99c674aac5af6fc8375083fee56da (diff)
downloadupstream-370ce1fb48ea8b5b8fc2f91ed536a4f306fa9c82.tar.gz
upstream-370ce1fb48ea8b5b8fc2f91ed536a4f306fa9c82.tar.bz2
upstream-370ce1fb48ea8b5b8fc2f91ed536a4f306fa9c82.zip
bcm53xx: use otrx for creating TRX images
The advantage is that we don't have to specify max TRX size anymore and otrx doesn't allocate a buffer of that size. It saves us allocating 32 MiB for every image we generate. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index e4dca0c4e9..596cb5ddb2 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -59,9 +59,7 @@ define Build/trx
endef
define Build/trx-serial
- $(STAGING_DIR_HOST)/bin/trx \
- -o $@.new \
- -m 33554432 \
+ $(STAGING_DIR_HOST)/bin/otrx create $@.new \
-f $(IMAGE_KERNEL) -a 1024 \
-f $@ -a 0x10000 -A $(KDIR)/fs_mark
mv $@.new $@
@@ -72,9 +70,7 @@ define Build/trx-nand
# if it grows up between releases
# root: UBI with one extra block containing UBI mark to trigger erasing
# rest of partition
- $(STAGING_DIR_HOST)/bin/trx \
- -o $@.new \
- -m 33554432 \
+ $(STAGING_DIR_HOST)/bin/otrx create $@.new \
-f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
-f $@ \
-A $(KDIR)/ubi_mark -a 0x20000