aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-10-02 00:19:58 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-10-02 00:22:57 +0200
commitba1024b9c921db36df2eae0ebb8adf5b648d4882 (patch)
tree767e575103a46ce188173c2656522db26169497c /target/linux/bcm53xx/image/Makefile
parent28974de663da517787045acd999be88714429261 (diff)
downloadupstream-ba1024b9c921db36df2eae0ebb8adf5b648d4882.tar.gz
upstream-ba1024b9c921db36df2eae0ebb8adf5b648d4882.tar.bz2
upstream-ba1024b9c921db36df2eae0ebb8adf5b648d4882.zip
bcm53xx: use the latest XHCI doorbell patch sent for upstream
The main difference is it supports DT binding. This allows us to use DT for specifying controller and the new standalone USB 3.0 PHY driver. Thanks to that we don't need out of tree patch adding PHY initialization to the controller driver anymore.
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 96368c12f4..9f56b22b4f 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -73,7 +73,7 @@ DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
BRCMFMAC_43602A1 := kmod-brcmfmac brcmfmac-firmware-43602a1-pcie
BRCMFMAC_4366B1 := kmod-brcmfmac brcmfmac-firmware-4366b1-pcie
USB2_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-phy-bcm-ns-usb2
-USB3_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-phy-bcm-ns-usb2
+USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
define Device/Default
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names