aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm4908/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-11-19 14:32:59 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-12-13 14:46:31 +0100
commitd5f9c6729fac914c2b4daecaf04377b8815e5740 (patch)
tree6b81574a6a7d789df9c651e8d62db0ed2b5315e3 /target/linux/bcm4908/image/Makefile
parent76ccf10c596d4b349706c87bdec908f4c48fbeed (diff)
downloadupstream-d5f9c6729fac914c2b4daecaf04377b8815e5740.tar.gz
upstream-d5f9c6729fac914c2b4daecaf04377b8815e5740.tar.bz2
upstream-d5f9c6729fac914c2b4daecaf04377b8815e5740.zip
bcm4908: start working on Netgear RAXE500 image
bootfs still needs more work before it's ready. For some unknown reason model RAXE500 uses board id RAX220. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 63ba3eaccddeb8058b0fabd69197e650735573bc)
Diffstat (limited to 'target/linux/bcm4908/image/Makefile')
-rw-r--r--target/linux/bcm4908/image/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index aa674c0142..71fca84fde 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -107,4 +107,20 @@ define Device/tplink_archer-c2300-v1
endef
TARGET_DEVICES += tplink_archer-c2300-v1
+define Device/netgear
+ DEVICE_VENDOR := NETGEAR
+ KERNEL := kernel-bin | bootfs
+ IMAGES := chk
+ IMAGE/chk := append-rootfs | pkgtb
+ NETGEAR_REGION := 1
+endef
+
+define Device/netgear_raxe500
+ DEVICE_MODEL := RAXE500
+ $(Device/netgear)
+ PKGTB_ITS := pkgtb-bcm4908.its
+ NETGEAR_BOARD_ID := U12H449T00_NETGEAR
+endef
+# TARGET_DEVICES += netgear_raxe500
+
$(eval $(call BuildImage))