aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm4908/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-11-19 14:32:58 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-12-13 14:46:31 +0100
commit97b76de5762214c5e4d4883234fee056b7155185 (patch)
treea0fb46600d42b883333af9fa18866b2f23ef8756 /target/linux/bcm4908/image/Makefile
parent1da38bb4db639938e71617bb7770ec322ac0d1b0 (diff)
downloadupstream-97b76de5762214c5e4d4883234fee056b7155185.tar.gz
upstream-97b76de5762214c5e4d4883234fee056b7155185.tar.bz2
upstream-97b76de5762214c5e4d4883234fee056b7155185.zip
bcm4908: continue work on images for U-Boot based devices
It still isn't ready though - more data needs to be added to the bootfs. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 494c033f9cbad67ea2cee3860894bdfffea65109)
Diffstat (limited to 'target/linux/bcm4908/image/Makefile')
-rw-r--r--target/linux/bcm4908/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index cbbbcbb526..aa674c0142 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -5,9 +5,11 @@ include $(INCLUDE_DIR)/image.mk
DEVICE_VARS += ASUS_PRODUCTID ASUS_BUILD_NO ASUS_FW_REV ASUS_EXT_NO
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_REGION
+DEVICE_VARS += PKGTB_ITS
define Image/Prepare
cp bootfs-generic.its $(KDIR)/
+ sed -i "s=\$$$${dts_dir}=$(DTS_DIR)=" $(KDIR)/bootfs-generic.its
endef
define Build/bootfs
@@ -49,6 +51,14 @@ define Build/bcm4908lzma
mv $@.new $@
endef
+define Build/pkgtb
+ mv $@ $@.rootfs
+ cp $(PKGTB_ITS) $@.its
+ sed -i "s=\$${bootfs}=$(KDIR)/bootfs-generic.itb=" $@.its
+ sed -i "s=\$${rootfs}=$@.rootfs=" $@.its
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@
+endef
+
define Device/Default
KERNEL := kernel-bin | bcm4908lzma | bcm4908kernel
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)